sIFR not working...


I have installed sIFR on a website that I am working on. It is installed correctly, the java is working enough to notice on Firebug, but for some reason the font isn't substituting.

www.classiccadillacdiner.com

H3 is the selector. Can anyone help me figure this one out
Posted On: Wednesday 17th of October 2012 03:45:31 AM Total Views:  118
View Complete with Replies

RELATED TOPICS OF JavaScript PROGRAMMING LANGUAGE




onsubmit function not working...

I want to perform the submit function before going to my summary page but it's not working...I even tried returning false. but still, it didn't work.. function submit(){ nodes = document.getElementsByClassName('check_boxes'); len = nodes.length; for (i = 0; i < len; i++) { nodes[i].removeAttribute("disabled"); } return true; }
VIEWS ON THIS POST

261

Posted on:

Saturday 10th November 2012
View Replies!

sifr and javascript

I'm using sIFR ( http://www.mikeindustries.com/blog/sifr/ ) in a website along with some javascript. The javascript makes the sizes of the two divs equal. And the javascript is run on window.onload. The problem is the sIFR seems to get rendered AFTER the scripts specified by window.onload. This means that the divs are made equal first by my script, and then the sIFR makes the text! So now the divs are not equal! The other solution was to run the script onclick, onfocus, onscroll, etc etc. But they're are all not very intuitive! What do i do
VIEWS ON THIS POST

46

Posted on:

Saturday 10th November 2012
View Replies!

ajax/mysql not working... pls help :)

, I wrote this AJAX script to process a php file to remove data from a MySQL database, but for some odd reason it isn't working so I've come here for some help, hopefully someone on here will be able to guide me to solving this issue :) Here's my AJAX script: //--> function removeBuddy(bud) { $.ajax({ type: "GET", url: "removeBuddy.php", data: "buddy="+ bud, success: function(msg){ $("#removed").ajaxComplete(function(event, request, settings){ if(msg == 'OK') { $("#removed").css("padding", "10px", "font-size", "8pt"); $(this).html(' You have successfully removed '+ bud +' from your buddy list...'); } else { $("#removed").css("padding", "10px", "font-size", "8pt"); $(this).html(msg); }); } }); } else { $("#removed").css("padding", "10px", "font-size", "8pt"); $("#removed").html('FATAL: There was an error while processing your request... Please try again'); } }); }); } //--> The PHP file "removeBuddy.php" has @ the top: $buddy = $_GET['buddy']; If the remove was a success then the PHP file echos "OK" which as you see on the AJAX script above, one more note when it is returned to the AJAX script it's put onto a DIV called "removed" using as ID and not CLASS. Although I think the PHP file is working but not the AJAX, which has baffled me totally... Any ideas
VIEWS ON THIS POST

208

Posted on:

Monday 19th November 2012
View Replies!

javascript onBlur() function not working...

Can any body tell me why my onblur() function is not working in javascript. Code is pretty simple. Its a text box with an onblur() function showing an alert. I have used it long back.. But i could not figure out why its not working now.. I dont know what the silly mistake i have made. Help me out if possible..
VIEWS ON THIS POST

150

Posted on:

Sunday 25th November 2012
View Replies!

JavaScript just randomly stopped working...

Hi , I made a minor change to a .js file, and it now fails to load on the HTML page. I think something is wrong with the if/else conditions, since even when I delete all the actual output I want and replace it with arbitrary String-based output, nothing is still outputted. With that being said, I see nothing wrong with the if/else conditions! Please help, as this is quite frustrating... Page that isn't loading the .js file: http://www.usc.uwo.c...s/WEGA/exec.htm The .js file: http://www.usc.uwo.c...ecscriptWEGA.js Note: other Javascript bits are working fine on the site, so I'm fairly certain it's not a server-side issue.
VIEWS ON THIS POST

138

Posted on:

Monday 26th November 2012
View Replies!

+= not working....

all! I'd like some help with some code to fade in and out banner images on my website. Basically, the idea is that every 10 seconds, the image will fade out as another image fades in. The way I am trying to accomplish this is by changing the opacity values of the two images. My problem is in the "fade" function. elem1 begins at opacity:1, whereas elem2 begins at opacity:0. When I decrement elem1.style.opacity, everything works just fine, but when I try to increment elem2.style.opacity, it successfully increments it the first time "step" is called, but then the opacity remains at .025 and won't increment any further. Does anyone have any ideas as to why this is Thank you for your help. var currentCount = 1; var imageCount = 3; var interval = .025; function changeImage() { var string = "b" + currentCount; currentCount++; if(currentCount > imageCount) { currentCount = 1; } var newString = "b" + currentCount; fadeOpacity(string, newString); } function fadeOpacity(string1, string2) { var elem1 = document.getElementById(string1); var elem2 = document.getElementById(string2); fade(elem1, elem2); } function fade(elem1, elem2) { step(elem1, elem2); if(elem1.style.opacity > 0) { window.setTimeout(fade(elem1, elem2), 25); } } function step(elem1, elem2) { elem2.style.opacity += interval; elem1.style.opacity -= interval; } function init() { document.getElementById("b1").style.opacity=1.0; document.getElementById("b2").style.opacity=0.0; document.getElementById("b3").style.opacity=0.0; window.setInterval(changeImage, 10000); } window.onload=init;
VIEWS ON THIS POST

118

Posted on:

Monday 26th November 2012
View Replies!

REL attribute not working...

Hi Im trying to make a script which when I click on the list element... it will replace a big image with anotehr picture. The list element is a thumbnail... and I want to swop the big image with the big version of the thumbnail. Each has a rel attribute... but while I can pull out each from the list, for some reason the following code, yields an 'undefined' value... instead of the big-image-path... Help! //getting all from the list of thumbnails var all_items = list.getElementsByTagName('li'); for(i in all_items) { //this should set the value of the big image //to the value of the rel attribute of the thumbnail list item all_items[i].onclick = function(){ main_image.src = dynamicImg('public/content/images/' + all_items[i].rel); }; }
VIEWS ON THIS POST

138

Posted on:

Monday 26th November 2012
View Replies!