Can't locate object method "readMessage" ... (Inheritance question)


I'm trying to create a package that overrides the 'new' method in the package: ElkM1::Control but use the rest of the methods as is. Here's my initial portion of my code (without the indent): package ElkM1::Control::Serial; use 5.008006; use strict; ...
Posted On: Wednesday 28th of November 2012 01:19:25 AM Total Views:  275
View Complete with Replies

RELATED TOPICS OF Perl PROGRAMMING LANGUAGE




I cant install Perl Module.

Hi folks. I very new to perl. I would like some one to help me. I need to install perl modules on my PC but cant get a head start.The Module converts Shpefiles to SVG format. I found it here.http://wiki.github.com/kbh3rd/shptosvg/I downloaded all the needed modules onto my Windows XP PC.Now in his writeup, he mentions that i need to install [Proj4 library] first before even using CPAN. I downloaded this too from http://trac.osgeo.org/proj/wiki/WikiStart#Download. Using my commandline, i navigated to the folder where i unzipped it. I perused through its read me, but i've failed to install it. I also downloaded a small software called Strawberry perl from http://strawberryperl.com/. But with it too. I cant get to install any thing. someone please help me. I need this shapefile to "svg converter".regards
VIEWS ON THIS POST

114

Posted on:

Sunday 4th November 2012
View Replies!

Can't locate object method is_initial_req

I am using AuthDBI with apache and I keep getting this error. Can't locate object method "is_initial_req" via package "Apache2::RequestRec I searched for is_initial_req and found the following site_perl/5.8.5/Apache/AuthDBI.pm: $type .= 'initial ' if $r- >is_initial_req(); site_perl/5.8.5/Apache/AuthDBI.pm: $type .= 'initial ' if $r- >is_initial_req; site_perl/5.8.5/Apache/AuthDBI.pm: unless $r->is_initial_req; # only the first internal request site_perl/5.8.5/Apache/AuthDBI.pm: $type .= 'initial ' if $r- >is_initial_req(); site_perl/5.8.5/Apache/AuthDBI.pm: $type .= 'initial ' if $r- >is_initial_req; site_perl/5.8.5/Apache/AuthDBI.pm: unless ($r->is_initial_req) { Binary file site_perl/5.8.5/i386-linux-thread-multi/auto/Apache2/ RequestUtil/RequestUtil.so matches site_perl/5.8.5/i386-linux-thread-multi/Apache2/RequestUtil.pm: $is_initial = $r->is_initial_req(); site_perl/5.8.5/i386-linux-thread-multi/Apache2/RequestUtil.pm:=head2 C site_perl/5.8.5/i386-linux-thread-multi/Apache2/RequestUtil.pm: $is_initial = $r->is_initial_req(); site_perl/5.8.5/i386-linux-thread-multi/Apache2/RequestRec.pm:C. site_perl/5.8.5/i386-linux-thread-multi/Apache2/SizeLimit.pm: if ($r->is_initial_req()) { site_perl/5.8.5/i386-linux-thread-multi/ModPerl/ MethodLookup.pm: 'is_initial_req' => [ Any ideas THanks.
VIEWS ON THIS POST

98

Posted on:

Sunday 4th November 2012
View Replies!

Can't locate object method "gif" via package "GD::Image"

Hi all, I have installed Perl-GD , and tried to use the GD::Image it throws the following error message , Can't locate object method "gif" via package "GD::Image" how can i eliminate the above error
VIEWS ON THIS POST

83

Posted on:

Monday 5th November 2012
View Replies!

cant find locally installed module

I have installed permute module locally and added the path to my script. However, perl fails to find the module. The script: #!/usr/bin/perl use lib "/u/basappas/local/perl/Algorithm-Permute-0.06"; use Algorithm::Permute; my @array = (1..9); Algorithm::Permute:ermute { print "@array\n" } @array; The files under /u/basappas/local/perl/Algorithm-Permute-0.06: bench Changes Makefile.PL META.yml Permute.c Permute.pm pm_to_blib typemap blib Makefile MANIFEST Permute.bs Permute.o Permute.xs test.pl The error: Can't locate Algorithm/Permute.pm in @INC (@INC contains: /u/basappas/local/perl/Algorithm-Permute-0.06 /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at Perm.pl line 3. BEGIN failed--compilation aborted at Perm.pl line 3. Please let me know if I am missing something...
VIEWS ON THIS POST

97

Posted on:

Wednesday 7th November 2012
View Replies!

mod_perl: can't locate object method...

hi group, i have the following problem: two servers, identically setup - at least i used the same files and when comparing everything (almost all) looks identical. both are configured with apche 2.0.x, mod_perl2. on both servers a mod_perl modul ...
VIEWS ON THIS POST

104

Posted on:

Saturday 10th November 2012
View Replies!

Tk::Browser, "Can't locate object method 'Construct'"

Using perl 5.10, I'm trying to run the Tk::Browser.pm SYNOPSIS example. I get a "Can't locate object method "Construct" via package "Tk::Widget" " error. In more detail --- use strict; use warnings; use Tk::Browser; my $b = new Browser; __END__ ...
VIEWS ON THIS POST

83

Posted on:

Monday 12th November 2012
View Replies!

Can't locate object method "host" via package "URI::_foreign"

Here is the complete error message: Can't locate object method "host" via package "URI::_foreign" at PERL2EXE_STORAG E/Net/SDEE/Session.pm line 108. I get this error when I run ssss.exe file. My ssss.pl file works fine, this error pops up after I ...
VIEWS ON THIS POST

106

Posted on:

Thursday 15th November 2012
View Replies!

ant locate object method _session_channel via package Net::SSH::Perl::SSH1

, I am trying to write a perl script using Net::SFTP which will login in to a remote file server running on https (port 443, its a Tumbleweed server), browse through some dirs and transfer some files dynamically. I started ...
VIEWS ON THIS POST

105

Posted on:

Thursday 15th November 2012
View Replies!

Re: Can't locate warnings.pm in @INC

Gunnar Hjalmarsson wrote: >> >> use CGI qw(:standard); >> use CGI::Carp qw(fatalsToBrowser); >> use DBI; >> use Time::localtime; > > It would surprise me if any of those modules requires 5.006, Noticed that the latest version of DBI does require ...
VIEWS ON THIS POST

92

Posted on:

Thursday 15th November 2012
View Replies!

threads, XSUB allocated memory, destructors, destruction

I have a perl module built out of XSUBs. The functions malloc() space, build structures and return pointers to perl. Perl calls their destructor routines with no problems. The C structures go back to the perl interpreter, as T_PTROBJ things, ...
VIEWS ON THIS POST

96

Posted on:

Thursday 15th November 2012
View Replies!

Net::SMTP error: Can't locate Mail/Sender.pm in @INC

Hi! I'm trying to get this short email script to work: #################################################### #!/usr/bin/perl -w use strict; use warnings; use Net::SMTP; use Net::POP3; my $mailhost = "smtp.mail.net"; my $mailobj = ""; if($mailobj = Net::SMTP->new($mailhost, Timeout=>10, Debug=>0)){ print("Connected to $mailhost\n"); } else ...
VIEWS ON THIS POST

109

Posted on:

Monday 19th November 2012
View Replies!

Error downloading page, some pages work great but cant seem to get this one

I am trying to download the source code for an array of differant websites, usually i will get something like this from Dilbert.com: HTTP/1.1 200 OK Date: Fri, 23 Apr 2004 00:04:54 GMT Server: Apache/1.3.27 (Unix) Resin/2.1.s030505 mod_ssl/2.8.14 OpenSSL/0.9.7b Last-Modified: ...
VIEWS ON THIS POST

91

Posted on:

Monday 19th November 2012
View Replies!

Can't locate wxPerl/Constructors/doc.pm in @INC

I am getting an @INC error when I have tried to run my script with wxPerl::Constructors. Here is the error below : C:\Documents and Settings\sp\Desktop\Perl>cgdpframe.pl Can't locate wxPerl/Constructors/doc.pm in @INC (@INC contains: C:/Perl/site/lib C:/Perl/lib .) at C:\Documents and Settings\sp\Desktop\Perl \cgdpframe.pl line 9. BEGIN failed--compilation aborted at C:\Documents and Settings\sp\Desktop\Perl\cgdpframe.pl line 9. I have tried using the path where it is "actually installed"(I believe), then I have used the below path at use lib as below in the code : use lib 'C:\Users\sp\AppData\Roaming\.cpanplus\5.16.1\build\wxPerl-Constructors-v0.0.4\lib\wxPerl'; Then the console threw the below error : C:\Documents and Settings\sp\Desktop\Perl>winframe.pl Can't locate wxPerl/Constructors/doc.pm in @INC (@INC contains: C:\Users\sp\AppData\Roaming\.cpanplus\5.16.1\build\wxPerl-Constructors-v0.0. 4\lib\wxPerl C:/Perl/site/lib C:/Perl/lib .) at C:\Documents and Settings\sp\Desktop\Perl\winframe.pl line 9. BEGIN failed--compilation aborted at C:\Documents and Settings\sp\Desktop\Perl\winframe.pl line 9. I have an Active Perl instance on my machine. Perviously, I used to have Strawberry Perl and Active Perl both, but then seeing the I am getting confused with both the perl distros. I have removed both of them and installed the new Active Perl on my machine, but could not able to remove the HKLM entries from the Registry Editor due to confusion of what to remove. I could able to install the Wx properly but this is happening when I have installed the wxPerl::Constructors. The install log for the same as attached. C:\Users\spullabhotla\AppData\Roaming\.cpanplus\install-logs\wxPerl-ConstruC:\Users\spullabhotla\AppData\Roaming\.cpanplus\install-logs\IPC-Run-0.92-1
VIEWS ON THIS POST

73

Posted on:

Saturday 24th November 2012
View Replies!

Re: Can't locate feature.pm in @INC

You are trying to use a feature that is in perl-5.10 and not in your installed version of perl 5.8.8. If you want switch functionality then you might want to install the Switch cpan module from which you will be ...
VIEWS ON THIS POST

70

Posted on:

Sunday 25th November 2012
View Replies!

Can't locate object method "newFromJpeg" via package "GD::Image"

Hi. I'm trying to execute this Perl simple script: -------- #!/usr/bin/perl use GD; my $srcimage = GD::Image->newFromJpeg("image_news.jpg"); my ($srcW,$srcH) = $srcimage->getBounds(); --------- But I get this error message: ------- Can't locate object method "newFromJpeg" via package "GD::Image" at ../test.pl line ...
VIEWS ON THIS POST

77

Posted on:

Sunday 25th November 2012
View Replies!

HOWTO - do local ppm module install (fix "Could not locate a PPDfile")

for ActiveState Perl 5.6 at least. I am offering this from my experience this morning with an urgent need to install and use the Date::Calc module (why on earth would that be left out of a default install It seems ...
VIEWS ON THIS POST

76

Posted on:

Sunday 25th November 2012
View Replies!

Taint mode slows down LWP::UserAgent->get significantly

I've got a CGI script that retrieves an approx. 8MB file from a server and does some checking on it before returning a result. I download the file using LWP::UserAgent. I have taint-checking enabled by default to verify CGI ...
VIEWS ON THIS POST

178

Posted on:

Monday 26th November 2012
View Replies!

"Can't locate object method "PV" via package "B::SPECIAL""

When I try to use B::Lint I get the error Can't locate object method "PV" via package "B::SPECIAL"" Does anyone know where B::SPECIAL is defined TIA, kj -- NOTE: In my address everything before the first period is backwards; and ...
VIEWS ON THIS POST

155

Posted on:

Monday 26th November 2012
View Replies!

unable to locate "IO::Socket::INET at ... /IO/Socket/INET.pm line 32

Sometimes, not always, an attempt to create a new socket connection fails with this message: Socket::INET" (perhaps you forgot to load "IO::Socket::INET") at /usr/local/lib/perl5/5.6.1/IO/Socket/INET.pm line 32 Any ideas why or how INET.pm fails saying it can't find INET.pm The script ...
VIEWS ON THIS POST

95

Posted on:

Monday 26th November 2012
View Replies!

=?windows-1252?Q?Can=92t_locate_Getopt=2Epm_in_=40INC?=

Dear Experts, I have a perl program that using Getopt:Std module, when I try to run the GetOpt program, the following error returned: Cant locate Getopt.pm in @INC (@INC contains: /opt/perl5/lib/5.00502/PA-RISC1.1 /opt/perl5/lib/5.00502 /opt/perl5/lib/site_perl/5.005/PA-RISC1.1 /opt/perl5 I am using Perl 5.6.1 in ...
VIEWS ON THIS POST

92

Posted on:

Monday 26th November 2012
View Replies!