Can't Query Database


Can someone please help before I go stark, raving mad!

I'm trying to query an access database through an asp page.\tI've set up a test at our home page on www.scotsinfo.com.;Our .asp and .inc files are in a sub-folder called "database" and our database is in the "private" folder, where it should be according to our host.\tClicking through to the .asp page gives the following error:

Microsoft OLE DB Provider for ODBC Drivers error '80004005'

[Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0xea4 Thread 0xbd4 DBC 0x29a67e4 Jet'.

/database/wed_asp_odbc.inc, line 415

Apparently this is a problem with the DBQ statement.\tHere is the relevant section from the .inc file:

Set Conn = Server.CreateObject("ADODB.Connection")
\t\tconString = "DBQ=" & Server.MapPath("\scotsinfo\private\test.mdb")
\t\tConn.Open "DRIVER={Microsoft Access Driver (*.mdb)};" & conString
\t\tset cursor = server.CreateObject("adodb.recordset")
\t\tcursor.cursortype = WED_CURSOR_TYPE
\t\tcursor.open sqlstr, Conn

I've tried every combination in the \scotsinfo\private\test.mdb path - no username, back slashes, forward slashes, you name it.\tStill I get similar error messges and am finally at a loss as to what to do next.
Posted On: Wednesday 2nd of January 2013 02:29:20 AM Total Views:  282
View Complete with Replies

RELATED TOPICS OF ASP.NET PROGRAMMING LANGUAGE




Godaddy SMTP Europe Server mail error

, I am doing my webpage with asp.net. I bought shared hosting plan from godaddy and everything was nearly fine until this problem occurred. I have tried to contact the "Help Team" of godaddy, but they were not able to help me. So what is wrong ! Well, I have written the code bellow for the mail contact form - "Contact.asp.cs". The code is working fine whenever I try it from localhost - but if it is on the server I keep getting error - "An error occured while sending your feedback." Unfortunately I could not get an exception of what is wrong. The answer from the "Help Team" was - "This feature is not supported" ! I have no idea what is wrong with the code It seems OK for me. Can you give me any hints what might cause the problem public partial class contacts : System.Web.UI.Page { const string MAIL_TO_SEND_TO = "mail@mydomainname.com"; const string MAIL_TO_SEND_FROM = "mail@mydomainname.com"; const string MAIL_PASSWORD = "password"; const string SUBJECT = "Feedback"; protected void Page_Load(object sender, EventArgs e) { btnSubmitComment.Click += new System.Web.UI.ImageClickEventHandler(btnSubmitComment_Click); mvComments.ActiveViewIndex = 0; } void btnSubmitComment_Click(object sender, System.Web.UI.ImageClickEventArgs e) { try { StringBuilder message = new StringBuilder(); message.Append("Name:" + this.txtName.Text + ""); message.Append("Email:" + this.txtEmail.Text + ""); message.Append("Company Name:" + this.txtCompany.Text + ""); message.Append("Comment:" + this.textAreaComment.Text + ""); SmtpClient mailClient = new SmtpClient("smtpout.europe.secureserver.net"); mailClient.Port = 25; mailClient.Credentials = new NetworkCredential(MAIL_TO_SEND_FROM, MAIL_PASSWORD); MailMessage mailMessage = new MailMessage(MAIL_TO_SEND_FROM, MAIL_TO_SEND_TO, SUBJECT, message.ToString()); mailMessage.IsBodyHtml = true; mailClient.EnableSsl = false; //mailClient.Send(mailMessage); mvComments.ActiveViewIndex = 1; } catch (Exception) { mvComments.ActiveViewIndex = 2; } finally { ScriptManager.RegisterStartupScript(this, this.GetType(), new Guid().ToString(), "endLoadingCursor()", true); } } } Here is the code from webconfig file: I have checked all the labels and there are no spelling errors.
VIEWS ON THIS POST

97

Posted on:

Friday 23rd November 2012
View Replies!

Events are not firing on web server

I am developing a website using asp.net visual studio.net 2003. I am working with xp professional service pack2 and using vb.net for coding. Everything is working fine on my local server but when I am uploading my website none of the events are firing. Please explain me the reason.
VIEWS ON THIS POST

88

Posted on:

Friday 23rd November 2012
View Replies!

DataSet error

I don't know where i went wrong. These are the links to the codes of my aspx.cs and aspx files respectively register.aspx.cs register.aspx This is my website url : registration form I would really appreciate your help. Thank you in advance.
VIEWS ON THIS POST

101

Posted on:

Saturday 24th November 2012
View Replies!

.Net framework source code is now available

.Net framework source code is now available for all to view. Check out all the details on my blog at http://weblogs.asp.n...e-unmasked.aspx
VIEWS ON THIS POST

82

Posted on:

Saturday 24th November 2012
View Replies!

help with Datalist rss

I setup a datalist with a xmldatasource and pull in an rss feed on my homepage I pull in this data ItemTemplate> I need to access the info from description in my code, to use it manipulate some things on my website How do I do this ive tried multiple methods on both the datalist and xmldatasource objects but can't seem to find the right one to access description Hope this makes sense
VIEWS ON THIS POST

85

Posted on:

Tuesday 27th November 2012
View Replies!

Print web page and pdf documents that are linked to the page

I have a request to create a batch print program that will print the contents of a web page as well any PDF documents that are linked to the page.For example a user fills out a contact information web form and uploads a resume to the site.\tI would like to create a method that will print the user's contact information and his pdf resume all in one step.\tThe interface will be an ASP.net web page and the PDFs will be stored in a SQL Server table.Has anyone tried this beforeEric
VIEWS ON THIS POST

208

Posted on:

Tuesday 27th November 2012
View Replies!

.ttx files on Crystal Report for ASP .Net

hi. would you know the different data types used to create a .ttx file for crystal reports i made one with one field of type numeric but when i tried to create a total field from this field, i dont get the deed result. it seems that my field is being treated as a string and not as a numeric field. what am i missing here would you give me the complete data types list
VIEWS ON THIS POST

138

Posted on:

Wednesday 28th November 2012
View Replies!

Request object

How do you get hold of the complete http message I want to write back to the browser what is being sent. Jon"I don't regret this, but I both rue and lament it."
VIEWS ON THIS POST

122

Posted on:

Tuesday 1st January 2013
View Replies!

Help with listing ODBC System DSN's

I am now working on a Login Prompt form that has username/password already working. I need to add one more feature which is to list the System DSN's in a drop down listbox. We have several users that work with different project databases so I want to give them a way to switch between different DSN's. Is this possible If so any tips or links to get started will be appreciated. Have a nice day.
VIEWS ON THIS POST

89

Posted on:

Tuesday 1st January 2013
View Replies!

COM Interop -> GetObjectContext

I have a web app that uses both asp and asp.net web pages. I call a COM (VB6) dll in my asp.net c# code, which works fine. But...the COM dll tries to get the ObjectContext, inorde rot get hold of the ASP Application object to read something it needs... When my ASP.NET page calls the COM dll, the dll never finds an ObjectContext, so I cannot get the information I need :( Is there something I can doI have read articles about adding the DLL to the Com+ aplications, but we don't use COM+/MTS, and when I tried that failed. I have also tried adding this to the page diretive: aspcompat="True". That doesn't help either.Can anyone help me
VIEWS ON THIS POST

140

Posted on:

Tuesday 1st January 2013
View Replies!

Read from File to update database

I need to read data from a pipe-delimited file, get the info I need out of it, and then update fields in a db.\tI can use the streamreader to open the file, and readline to read a whole line of data.\tWhat's the best way to parse through that data, look for the pipes, and separate out any data that I need\tDoes that make sense
VIEWS ON THIS POST

87

Posted on:

Tuesday 1st January 2013
View Replies!

The best way to send a large number of emails

I have around 100,000 email addresses I want to send an email to each of this customer.What is the best way to send emails to these customersI appreciate any idea,suggestion or comment.Thank you
VIEWS ON THIS POST

68

Posted on:

Tuesday 1st January 2013
View Replies!

Web Service WSDL question for a newbie

I am new to web service and need a few questions answered by anyone out there willing to answer them.\tI have been given a WSDL file to use and need to create a client to access the web service belonging to that WSDL file.\tWe will also be using SOAP methods.Question 1 - Where do I start\tQuestion 2 - Do I need to create my own web service or can I use existing ASP pages with some modifications\tI would prefer to use existing ASP pages and just make function call modifications if I can do that.Question 3 - Can anyone direct me to some good tutorials on create a client using WSDL SOAP and ASPQuestion 4 - How about good books on Web Services and SOAP integration.As you can see, I am very new to web services.\tI do have a pretty good .NET and C# background as well as a web development background.\tANy help you can provide would be greatly appreciated.
VIEWS ON THIS POST

83

Posted on:

Tuesday 1st January 2013
View Replies!

180 sessionvariables..?

Hi all,I'm trying to give 180 sessionvariables a value from a table.I have tried:Dim MyObj As Object,intCnt As Integer, intTest As IntegerFor intCnt = 0 To 180\t\t\t\t\t\tMyObj = myDS.Tables(0).Rows(intCnt).Item("myField")\t\t\t\t\t\tintTest = MyObj\t\t\t\t\t\tSession(intCnt.ToString) = intTestNext/Kent J.
VIEWS ON THIS POST

94

Posted on:

Tuesday 1st January 2013
View Replies!

SQL string works in access but not from VB.Net code

My page is in VB.Net, and tries to do an OleDB.ExecuteNonQuery on this string:INSERT INTO tblGCardDetails (OrderID, Image) VALUES(5924045, '0007')I get an System.Data.OleDb.OleDbException: Syntax error in my code. The same string works when dropped into an Access query. What could I be missing
VIEWS ON THIS POST

80

Posted on:

Tuesday 1st January 2013
View Replies!

Tricky Problem Displaying Information

I've been messing with this problem for hours now and have decided to look for some advice on this forum.I have a page which loads information from a Db and displays it. Easy enough. The problem I'm having is with displaying some optional data. I want to create a list of delivery addresses for a customer on the page. I am planning to have asp controlled links that when clicked will display the full address below them. I thought this was going to be quite easy.I started with a sub that worked out which link had been clicked and then went on to display the address but I couldn't get it to place labels. I've had so many different attempts and issues I won't list them all.If anyone can think how I could go about this it would be great. I may well crack the idea soon, but I have a feeling it will be an unprofessional bodge that I end up using. ideas welcome. Cheers
VIEWS ON THIS POST

88

Posted on:

Tuesday 1st January 2013
View Replies!

Question datagird table

Hi all,My question is that is there any way we can put the mouse cusor in the datagrid table after we post it on the browser to modify the data in a row Because, right now I can post the datagrid on the web browser but I can not put the cusor to the row inside the grid table.
VIEWS ON THIS POST

88

Posted on:

Tuesday 1st January 2013
View Replies!

Using an ASP.Net page as a presentation

We run a plasma screen in the office here, that shows a variety of information for the internal staff.currently we run a powerpoint presentation, which being run 24/7 has a habit of freezing requiring me to close the presentation and running at again once a day.We are thinking of replaceing it with an ASP.Net page on a timed refresh that can read data from a databse, as well as having a backend system for users to update information.Since this will be running in a fullscreen web-browser, is there a way for the HTML to scale so that it does not run off the screen boundaiesAre there any other problems people can think of for running a system like this (session state being maintained 24/7).
VIEWS ON THIS POST

67

Posted on:

Tuesday 1st January 2013
View Replies!

Progress Indicator

I have to be able to find this somewhere.\tDoes anyone know how I can pop up a progress indicator to show my user(s) that something is happening while they wait\tI have seen it done, but I cannot find any good resources to help me figure out how to do it.\tI have a great anim image that says loading, and I could use that. Or, a progress bar inside of .NET, fine with me.\tJust something.\tI am using VS.NET, vb and ASP.NET on IIS and Win2k.
VIEWS ON THIS POST

78

Posted on:

Tuesday 1st January 2013
View Replies!

Namespace could not be found

I created a namespace consisting of two cs files (uSqlREBrokers.cs and uSqlREProperties.cs). This namespace references another namespace. The compile command line I used to create the namespace or the dll file ( uSqlRE.dll) iscsc /target:library /out:uSqlRE.dll /R:yJCore.DLL uSqlREBrokers.cs uSqlREProperties.csI now have an aspx file (loginnew03.aspx) which inherits from a code behind file (loginnew03.cs).The code behind file has this statementusing uSqlRe;When I load loginnew03.aspx into internet explorer, i get the following compilation errorCS0246: The type or namespace name 'uSqlRE' could not be found (are you missing a using directive or an assembly reference)What should I do to correct this
VIEWS ON THIS POST

105

Posted on:

Tuesday 1st January 2013
View Replies!

New browser window & passing parameters...

Hi!!!I want to open a page in a new window, the problem is I need to pass some parameters to the new page...I'd already try a javascript function but it doesn't work...Thank you verry much...
VIEWS ON THIS POST

86

Posted on:

Tuesday 1st January 2013
View Replies!

XMlDoc to dataset hierarchy problem

On a C#.net site I've been asked to take over the programmer converts an XmlDoc to a dataset. \t\t\t\t\t\t\tXmlDoc resultDoc = new XmlDoc();\t\t\t\t\t\t\t...\t\t\t\t\t\t\t\tresultDoc.LoadXml(text);\t\t\t\t\t\t\t\tresultDoc.LoadXml(resultDoc.SelectSingleNode("//return").InnerXml);\t\t\t\t\t\t\t\tDataSet ds = new DataSet();\t\t\t\t\t\t\t\tds.ReadXml((new StringReader(resultDoc.OuterXml)));\t\t\t\t\t\t\t\t\t\tRadioButtonList1.DataSource = ds;\t\t\t\t\t\t\t\t\t\tRadioButtonList1.DataTextField = "business"; \t\t\t\t\t\t\t\t\t\tRadioButtonList1.DataBind();Ive seen this done before on a flat xml file, but the xml being used in this case (from a web service) is something like\t\t0x00000000000D0830\tS4DTest...\t\t10\t\t\t\t......In his code he uses the lineRadioButtonList1.DataTextField = "business"; to get the business name. this is fine and works, but they want me to now use the building number instead of the business name. I can't think how I refer to this. Ive triedRadioButtonList1.DataTextField = "building"; RadioButtonList1.DataTextField = "address/building"; // unlikely but in desperation triedevenRadioButtonList1.DataTextField = "address"; in the hope it might give the entire address with tabs that I could strip the building out of but it doesn't recognise Is there anyway I can refer to the building field in the ds, or is it simply not converte
VIEWS ON THIS POST

72

Posted on:

Tuesday 1st January 2013
View Replies!

How can I display asterisk for password in Gridview

I am trying to bind data from database and display on the gridview, but want to display password as asterisk.\tI tried so many ways but can;t get it.\tPlease help\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t E-Mail Address:\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\tPassword*:\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\tVerify Password*:\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t , When the data just displays in the grid, it is using a lable to display the data, not a textbox.\tSo, setting the textbox mode to password only will work in edit mode.\tIf you want to display an asterisk(s) then you will have to return them in\tyour sql.
VIEWS ON THIS POST

66

Posted on:

Tuesday 1st January 2013
View Replies!

C# ASP.NET Dynamically Changing the Datasource of a ListBox

Hi all,I've been stuck on this error for a harrowing amount of time, so I thought I'd bring my lamentations here. I'll try here to provide as much information as possible.I have two buttons with the following code in my ASP.NET page:CODE\tprotected void AddUsersBtn_Click(object sender, EventArgs e)\t\t{\t\t\t\tString opName = "add";\t\t\t\tString grpId = GroupList.SelectedItem.ToString();\t\t\t\tString url = "UserToGroupListDialog.aspxOperation="+opName+"&SelectedGrp="+grpId;\t\t\t\tString execScript = "callPopup('" + url + "');";\t\t\t\t\t\t\t\tPage.ClientScript.RegisterClientScriptBlock(this.GetType(), "addUsersToGrpsDialog", execScript, true);\t\t}\t\tprotected void RemoveUsersBtn_Click(object sender, EventArgs e)\t\t{\t\t\t\tString opName = "remove";\t\t\t\tString grpId = GroupList.SelectedItem.ToString();\t\t\t\tString url = "UserToGroupListDialog.aspxOperation="+opName+"&SelectedGrp="+grpId;\t\t\t\tString execScript = "callPopup('" + url + "');";\t\t\t\tPage.ClientScript.RegisterClientScriptBlock(this.GetType(), "removeUsersFromGrpsDialog", execScript, true);\t\t} Now, the purpose of these buttons is to open up another .aspx page with a listbox that is databound to a datasource depending on the operation (the operations 'add' or 'remove' are passed as part of the query string).When I click the add users button, everything works fine and the list gets populated as expected. However, if I click on the remove users button, the listbox does not populate.I have two datasource controls on the page to which the buttons are redirecting the user (UserToGroupListDialog.aspx i.e.). Here is the code for what I'm doing on page load:CODE protected void Page_Load(object sender, EventArgs e)\t\t{\t\t\t\tString opName = Request.QueryString["Operation"];\t\t\t\t\t\tif (!Page.IsPostBack)\t\t\t\t{\t\t\t\t\t\tPage.ClientScript.RegisterClientScriptInclude("functions", "js/showDialog.js");\t\t\t\t\t\tif (opName.Equals("add"))\t\t\t\t\t\t{\t\t\t\t\t\t\t\tAvailUsersList.DataSourceID = "TXDatabaseAvailableUsersDataSource";\t\t\t\t\t\t\t\tAvailUsersList.DataTextField = "UserName";\t\t\t\t\t\t\t\tAvailUsersList.DataValueField = "UserName";\t\t\t\t\t\t\t\tAvailUsersList.DataBind();\t\t\t\t\t\t}\t\t\t\t\t\tif (opName.Equals("remove"))\t\t\t\t\t\t{\t\t\t\t\t\t\t\tAvailUsersList.DataSourceID = "TXDatabaseRemoveAvailableUsersDataSource";\t\t\t\t\t\t\t\tAvailUsersList.DataTextField = "UserName";\t\t\t\t\t\t\t\tAvailUsersList.DataValueField = "UserName";\t\t\t\t\t\t\t\tAvailUsersList.DataBind();\t\t\t\t\t\t}\t\t\t\t\t\t\t\tSelectedGrpLbl.Text = Request.QueryString["SelectedGrp"].ToString(); // set selected group\t\t\t\t\t\t\t\t\t\t\t\tif (SelectedGrpLbl.Text == null || SelectedGrpLbl.Text == "")\t\t\t\t\t\t\t\tSelectedGrpLbl.Text = "Error!";\t\t\t\t\t\tCancelOperationBtn.Attributes.Add("onclick", "window.opener = self; window.close();");\t\t\t\t}\t\t} As you can see, I'm doing exactly the same thing with the listbox, except that I'm changing the datasource to which it is going to be bound. I have checked the queries that are configured to the datasource controls and they work as expected (they both run stored procedures to get the dataset that needs to be populated onto the listbox).There is no problem with the query string either and the name-value pairs get passed on to the page as expected. I also tested whether the "remove" if condition is checked and entered into when the redirection happens, and it does.So why isn't the remove users datasource control populating the listbox when the remove users button is pressed on the parent page What am I missing hereAppreciate your guidance on this as I cannot fathom what the source of the problem is.Thank you. Will be glad to provide more information as necessary.
VIEWS ON THIS POST

74

Posted on:

Tuesday 1st January 2013
View Replies!

Slow application after upgrading from 1.1 to 2.0

our web site contians Web Application1 (.net 2.0) = the web stie\t\tWeb Application2 (.net 2.0) = virtual directory\t\tWeb Application3 (classic ASP) = virtual directoryAfter we upgraded our server from .net 1.1 to 2.0 the Web Application2 is very slow (web application1 and web application3 are fast as usual). why- all applications use same connection string to communicate with our database.- we have installed .net 2.0 and Service Pack 1 for it.- I have changed the asp.net under asp.net tab under property of the web site
VIEWS ON THIS POST

258

Posted on:

Tuesday 1st January 2013
View Replies!

Web service session problem

Dear all,Im trying to figure out how session variables work in web services, but obviously I found myself in trouble. I would appreciate your help.I create a web service with following Global.asax and Service.asmx files//Global.asaxprotected void Session_Start(Object sender, EventArgs e){\t\tSession[TID] = 1;}//Service.asmx[WebMethod(EnableSession=true)]public int CalculateSession(){Session[TID] = ((int)Session[TID]) + 1;return (int) Session[TID];}Problem starts when I call a web service from Console Application (previously I add web service in a project via Add Web references)namespace Client{\t\t/// \t\t/// Summary description for Class1.\t\t/// \t\tclass Class1\t\t{\t\t\t\t/// \t\t\t\t/// The main entry point for the application.\t\t\t\t/// \t\t\t\t[STAThread]\t\t\t\tstatic void Main(string[] args)\t\t\t\t{\t\t\t\t\t\tlocalhost.WebService ws = new localhost.WebService()\t\t\t\t\t\tfor (int i=0; i
VIEWS ON THIS POST

77

Posted on:

Wednesday 2nd January 2013
View Replies!

Record MachineName & PageTitle to db

I need to record MachineName and PageTitle to DB for a survey purpose. ASPX pages used in our intranet.What is the best way to do thatCODEDim Machine_Name As String = System.Environment.MachineNameDim Page_Title As String = Page.TitleThese informations I need to record.OnLoad Event I am getting a Null Reference error
VIEWS ON THIS POST

87

Posted on:

Wednesday 2nd January 2013
View Replies!

Populate Details View

I have a page that has a GridView and Details view on it. the detailsview is only used for Inserting, thus my default mode is set to insert. I created a VB Sub that populates some of the detailsview fields with data from the gridview. that works great when the page is first loaded, once I insert the detailsview data and the page postsback the fields in the detailsview are no longer populated with the dynamic data from the gridview.Here is my relevent code.CODE 'Find the Address,LastName and Phone of Employee in 'Gridview and populate the Detailsview controls with that 'dataProtected Sub gvEmpDbound(ByVal sender As Object, ByVal e As GridViewRowEventArgs) Handles gvEmployee.RowDataBound\t\t\t\tDim dv As DetailsView = dvNewDepend\t\t\t\tDim gv As GridView = gvEmployee\t\t\t\tDim EmpIDVar As Int32 = Request.QueryString("EmpID")\t\t\t\tIf e.Row.RowType = DataControlRowType.DataRow Then\t\t\t\t\t\tEmpLastNM = Convert.ToString(DataBinder.Eval(e.Row.DataItem, "Last_Nm"))\t\t\t\t\t\tEmpAddress = Convert.ToString(DataBinder.Eval(e.Row.DataItem, "address"))\t\t\t\t\t\tEmpPhone = Convert.ToString(DataBinder.Eval(e.Row.DataItem, "hmphone"))\t\t\t\tEnd If\t\t\t\tDim LastNM As TextBox = dv.FindControl("TxtLastNM")\t\t\t\tDim Address As TextBox = dv.FindControl("TxtAddress")\t\t\t\tDim Phone As TextBox = dv.FindControl("TxtPhone")\t\t\t\tDim lblEmpID As Label = dv.FindControl("lblEmpID")\t\t\t\tlblEmpID.Text = EmpIDVar\t\t\t\tLastNM.Text = EmpLastNM\t\t\t\tAddress.Text = EmpAddress\t\t\t\tPhone.Text = EmpPhone\t\tEnd Sub'added these lines to see if binding the data would 'repopulate 'the details view to no availProtected Sub dvNewDepend_ItemInserted(ByVal sender As Object, ByVal e As System.Web.UI.WebControls.DetailsViewInsertedEventArgs) Handles dvNewDepend.ItemInserted\t\t\t\tgvEmployee.DataBind()\t\t\t\t
VIEWS ON THIS POST

75

Posted on:

Wednesday 2nd January 2013
View Replies!

convert string back to hashtable

i'm just starting my ventures into .NETi'm trying to create a hash table to store in a cookie and then read it back as a string, convert it back to a hashtable and life is all good.i dont know how to read it back though. Below is the 2 chunks of code i'm using to attempt this. The second chunch (the part that reads it) is the part that isn't working. I dont really expect it to in its current form, but in included it so you could see what I am trying to accomplish.
VIEWS ON THIS POST

86

Posted on:

Wednesday 2nd January 2013
View Replies!

SQL Server Database Roles through ASP?

Hi all,I'm a bit new to ASP so I have what may be a foolish question. The ASP role management options that come through "roleManager" are great but, as far as I can tell, they do everything through the "aspnet_*" tables in the DB. What I would really like to do is access the Database roles I've created directly in SQL Server 2005 via my ASP application. Does anyone know a way to do this I've searched around a bit online and come up with nothing, but a link to a good tutorial would be much appreciated if such a thing exists
VIEWS ON THIS POST

50

Posted on:

Wednesday 2nd January 2013
View Replies!

insert ID into my Function

hi am making a blog or something like it and i want to get the number of comments. so i created a function this is what am trying to do, its inside a repeater control. GetByID is my function and it takes a string and i want to add Eval("ID") to the string
VIEWS ON THIS POST

73

Posted on:

Wednesday 2nd January 2013
View Replies!

datagrid hyperlink to new page/new datagrid

Hi all,I am working on a datagrid on weborm1.aspx, with a hyperlink column passing the record ID column along with the url like so:http://localhost.webform2.aspxid={0}I have a datagrid on webform2 that I want to use the id passed from webform1.aspx as the selection in my SQL statement.I am confused as to how I call that id that was passed.\tI see that I can assign the id to a variable in code in the PageLoad event but how do use that variable in a SQLdataadapter which loads the dataset which loads the new datagrid.\tI am thinking I have to re-fill the dataset with a new SELECT statement but am having trouble doing it.\tAny suggestions
VIEWS ON THIS POST

66

Posted on:

Wednesday 2nd January 2013
View Replies!

Password Reset Complexity Settings

i recently changed the password complexity as follows :\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\tThis works fine.However , if a user forgets there password and needs a new one, they answer a security question, and then a new password is sent to them via email.Te password that is sent is a complex one : eg :Password: #!FO5:U:!;VQ*cI wondered if there was any way to change the web config file so that the new password that is emailed to the user isnt complex. Such that it just contains letters and has a lengh of 5 characters .Any guidance would be appreciated
VIEWS ON THIS POST

71

Posted on:

Wednesday 2nd January 2013
View Replies!

Losing Session Variable on Page Post Back

Ok, here is my problem. I have a series of pages which depend on a session variable. This session variable is created from an integer identity field in the sql server 2000 database table. After the 1st page, each subsequent page reads this session variable at the beginning of each page. \tThe Second page of the sequence reads the session variable on the page load method. But any calls to this session variable after the page load method, return empty. Somehow, it is losing the session. I have done lots of research, but cannt\tfind similar situations. Another option is to use the SQL server session method. But this is slower, so i have not tried it yet. If anybody has experienced this, please help.
VIEWS ON THIS POST

78

Posted on:

Wednesday 2nd January 2013
View Replies!

List control help

How do I do the tabing window or 'listcontrol' in asp.netLike on this page:http://dotnetcharting.com/cases/display.asp
VIEWS ON THIS POST

96

Posted on:

Wednesday 2nd January 2013
View Replies!

users share name and pass

Need some advice here..Suppose that there is a login form that a user fills in the username and a password. Somehow the "credential" are checked and he may reach the default.aspx webform. I need ,if possible, to make sure that if he has shared the username and pass with an other user, that they cannot both login. thnx
VIEWS ON THIS POST

92

Posted on:

Wednesday 2nd January 2013
View Replies!

Using FindControl

How can I change the text property of this textbox:\t\tFindControl("tb" & "AddToCart_Item_" & intProdID).ID()to equal "0"
VIEWS ON THIS POST

101

Posted on:

Wednesday 2nd January 2013
View Replies!

INamingContainer - CreateInstance of Composite Control

Guys,Need some help!!\tI have numerous composite controls that I need to render based on what step in a wizard that a user is at.\tThese controls will be rendered 1 at a time.\tI have created my templated composite controls and am using the Activator.CreateInstance to create which ever control needs to be created.\tThe creation of the controls and rendering isn't a problem.\tI run into issues trying to capture the events coming off child controls (buttons, etc...) within the composite control that is being displayed.\tI have the INamingContainer interface in place to create unique ids for the child controls, but when you look at the "View Source" of the rendered page the name given to these inner most child controls are not showing an elongated name, like the parent controls are showing.One of my parent controls has a name: "Left:blah_blah_blah:_ctl0:ctl1"One of my inner-most child buttons has a name of: "_ctl2"It just seems really strange that the inner most control has such a short name, being that the INamingContainer (I thought) was suppose to be pinpointing the location of the control.Is this normal or am I totally losing it\tAny thoughts or help is greatly appreciated!!
VIEWS ON THIS POST

65

Posted on:

Wednesday 2nd January 2013
View Replies!

Passing an array to a custom dll

,I have created a custom dll that accepts a 2-dimensional string array.\tThe array holds all the product info for an online order form.\tThe dll processes through that array and returns the cheapest freight carrier and the price.The problem is that this array takes about 1-2 seconds to build, but takes a long time for it to be passed to the dll.\tI\ttried sending the array by reference and go the same results.How can I speed up this process
VIEWS ON THIS POST

64

Posted on:

Wednesday 2nd January 2013
View Replies!

ViewState build errors

I have an arraylist which takes in values and im trying to add values to the array list everytime the button is clicked.\tIm trying to use the viewstate but seem to be getting the following build error. 'System.Web.UI.Control.ViewState' denotes a 'property' where a 'method' was expectedCan someone please tell me what I have done wrong. Here is the code which I have added to the web form below
VIEWS ON THIS POST

197

Posted on:

Wednesday 2nd January 2013
View Replies!

Problem setting up Security with DWMX and asp.net

I am running DWMX on a W2K and can't seem to get the security to run on my system.\tI need to set up a Virtual Directory, apparently, but when I do, thereHere is my Web.config file:**********************************************************************\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t\t**********************************************************************I first got this error before I set up my folder "c:\inetpub\wwwroot\contouraerospace\" as a virtual directory.*********************************************************************Configuration ErrorDescription: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.Source Error:Line 9:\t\t\tLine 10: \t\t\t\tLine 11: \t\t\t\tLine 12: \t\t\t\t\t\tLine 13: \t\t\t\t\t\t\t\tSource File: c:\inetpub\wwwroot\contouraerospace\web.config\t\tLine: 11*********************************************************************After I set up the "contouraerospace" folder as a virtual directoy, I get this error:***********************************************************************Server Error in '/ContourAerospace' Application.Parser ErrorDescription: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.Parser Error Message: File or assembly name DreamweaverCtrls, or one of its dependencies, was not found.Source Error:Line 1:\tLine 2:\tLine 3:\t
VIEWS ON THIS POST

140

Posted on:

Wednesday 2nd January 2013
View Replies!

aspx production and deployment

hi,I used to create aspx in one page, the html and the code. everytime I am done with an aspx page,I upload it to the server and I am able to view it via the browser. I never used visual studio before. Someone recommended me to use it and I did.My question, when I create one aspx page in my local pc then I want to put it in a production server, I copied all three pages(SalesReport.aspx & SalesReport.aspx.vb & SalesReport.aspx.resxI tried to run it but was not able to do so. and I got the following messageParser Error Message: Could not load type 'Pcx.SalesReport'.Source Error: Line 1:\tLine 2:\tLine 3:\tSource File: D:\PCx\SalesReport.aspx\t\tLine: 1 ---------------------------------------------------------Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET Version:1.1.4322.573 How can I overcome this issue
VIEWS ON THIS POST

58

Posted on:

Wednesday 2nd January 2013
View Replies!

Removing the Title Bar from a webform

Can anyone tell me how to completely remove all of the tool bars and title bars from a webform\tI want a page to have only want i putinto the web design part of the form with no minimize or close buttons
VIEWS ON THIS POST

48

Posted on:

Wednesday 2nd January 2013
View Replies!

Virtual Dir / Visual Studio Project folder issue

Running IIS locally on Win2K.I have an ASP(VB).NET solution I'm working on in Visual Studio.NET.\tThe root directory exists in IIS.\tI want to put my javascript files in a separate folder called 'scripts', so that they're called from the aspx pages with 'scripts/coolmenu4.js', for example.\tAnd I also want to put them in a 'scripts' folder in the VS.NET project, to keep them organized.How to I get this to workI don't understand the association between the project folder and the virtual folder, and when I save changes to the scripts, they save in 'C:\inetpub\wwwroot\webapp1\scripts...as if that's the real physical path.\tBut it's not.\tThe virtual 'scripts' directory is mapped to the E: drive.\tHow do I straighten this out
VIEWS ON THIS POST

59

Posted on:

Wednesday 2nd January 2013
View Replies!

Create Excel File

I want to dynamically create an Excel file from my aspx page. I am having trouble finding examples on how to do this! Does anyone have a basic example they could share with me, including what Namespace has to be used
VIEWS ON THIS POST

79

Posted on:

Wednesday 2nd January 2013
View Replies!

cookie problem

got a protected page that upon successful login, the user is greeted with their name and expiration date.\tthat is expiration date of service, not their personal date of demise.\ti hope.\tpoor humor if any at all.anyway, it works fine for most systems.\ti simply put the name and date on a cookie value and display it to them using a label.\tbut i have one user that complained of a runtime error.\ti do have 3 machines, and wouldn't you know, on one of those machines i get a runtime error.\t"object not set to an instance of an object".\ti am wondering if it has something to do with how each browser is set up for cookies.\tthe machine of mine that is giving this error does accept cookies.\tso i am lost.\tany help appreciated
VIEWS ON THIS POST

81

Posted on:

Wednesday 2nd January 2013
View Replies!

VS.NET Setup on Web Server

I believe I have VS.NET installed properly on my local machine, but I noticed that the web server (remote) only has the .NET Framework installed.What is EVERYTHING that the web server should have installedVS.NET Server ComponentsAnything elseWhat is the proper procedure to have these confugrations installed
VIEWS ON THIS POST

56

Posted on:

Wednesday 2nd January 2013
View Replies!

Server Error in '/' Application

Hi ,I'm trying to run my first ASP.Net app, but I'm getting this error. Is wrotten in the page that opens that a shoul set the value CustomerErrors tag property called mode to Off to see the details of the error. I 've done it, but everything seems to be exactly the same.Can anyone help meThanx.Jos Maurcio.
VIEWS ON THIS POST

53

Posted on:

Wednesday 2nd January 2013
View Replies!

Working with a radiobuttonlist

I have a radiolist that I want to have one of the buttons\tpreselected when the page loads based on a database object. How can I do this Right now I am string that value in a string and doing a if statement, but I don't know how to tell the radio button to be selected already.
VIEWS ON THIS POST

63

Posted on:

Wednesday 2nd January 2013
View Replies!

Datagrids

If your wanting to only show one record from a database that has many columns can you use a datagrid that will put each column into its own row How would you do this
VIEWS ON THIS POST

56

Posted on:

Wednesday 2nd January 2013
View Replies!