Showing Combo box List in UpWard Direction


Hi    I am Delphi developer which is very similar to VB. I have a combo box on the form & it has list of entries. I want to show the list in upward direction when click on this combo box. Can anybody help in this Suggestions in VB are welcomed. Thanx
Posted On: Thursday 13th of September 2012 10:18:36 PM Total Views:  41
View Complete with Replies

RELATED TOPICS OF Visual Basic PROGRAMMING LANGUAGE




PropertyGrid only showing base class

Is there any way to make the propertygrid show the form/control you are working no and not just the base class properties I created a new application and added a single property: public partial class Form1 : Form { public Form1() { InitializeComponent(); } int aaa = 0; public int AAAA { get { return aaa; } set { aaa = value; } } } The propertygrid says it's showing properties for System.Windows.Forms.Form, not MyApplication.Form1. If I add a Form2 based off of Form1, then the propertygrid says it's showing properties for MyApplication.Form1 (even though I'm working on Form2), and my property is there.
VIEWS ON THIS POST

56

Posted on:

Saturday 22nd September 2012
View Replies!

Data Report is not showing The recently added data in the database

hi I m using vb/access . my form gets some data and save them to the database using adodc.recordset it works fine. but when i show my data report it shows the added data fine first time . and when i add some more data and i show the datareport it doesn't show the data added later(2nd time) i m in trouble pls help me. i m using data environment for generating report. i think dataenv connection is not requering from database every time...
VIEWS ON THIS POST

142

Posted on:

Monday 24th September 2012
View Replies!

Unicode characters showing as ?

I have developed an application and need to allow users to enter text in any language and save it to my database. However the text is saved as '' in my database. I have googled quite a bit and found that people have suggested not to use varchar, text types but use nvarchar and ntext etc in your database. I have gone through and made these changes to my database. However it still saved text as '', I then found people where saying about adding 'N' infront of the text prior to saving into the database. The problem is that I cannot figure out how to do this in a stored procedure. Stored ProcedureCREATE PROCEDURE [dbo].[spUpdateActionTaken] @ID as varChar(4),@action as text,@modifyDate as varchar(50) AS UPDATE commentsTbl SET commActionTaken=@action,modifyDate=@modifyDate WHERE [ID]=@ID Note: Fields commActionTaken set to nText VB.Net CodeDim actionTaken as String = Me.textBox.TextDim myCmd As New OleDb.OleDbCommand("spUpdateActionTaken")myCmd.CommandType = CommandType.StoredProceduremyCmd.Parameters.Add(New OleDb.OleDbParameter("@ID", OleDb.OleDbType.VarChar)).Value = IDmyCmd.Parameters.Add(New OleDb.OleDbParameter("@action", OleDb.OleDbType.VarChar)).Value = actionTakenmyCmd.Parameters.Add(New OleDb.OleDbParameter("@modifyDate", OleDb.OleDbType.Date)).Value = Now() I am assuming that this is the solution or do I have to change anything else in the database I am using MS SQL 2000 database.
VIEWS ON THIS POST

105

Posted on:

Wednesday 26th September 2012
View Replies!

Install app in Win7 with icon showing in System Tray by default.

I have a custom app which I deploy to my Win7 users, the app sets up a tray icon which is automatically hidden by the OS. The user then has to manually change the settings of the System Tray to always display my app's icon.What can I do when installing my app on Win7 to make the icon show in the System Tray without user-intervention
VIEWS ON THIS POST

114

Posted on:

Monday 1st October 2012
View Replies!

[answered] MapPoint maps not showing up under different user?

I've built a small application that interacts with MP 2010. The Admin installed MP 2010 and my application and both work fine. The machine is Windows XP SP3. If another user logs onto that machine, they can run MP 2010 fine. My application will start but there are no maps. Database queries, etc. all run fine. But no maps. I configured the application to use " Users" (which is selected by default when installing). Is there something else I need to do to have it show the maps Is there some way to have my program always run as though it's being run by the Administrator
VIEWS ON THIS POST

111

Posted on:

Wednesday 3rd October 2012
View Replies!

No data showing in Crystal Report only the headings, WHY ???

I am fairly new to Crystal Reports, and so might be excused for what to some will be an easy question to answer, I am writing my program in VB 2008 and wanting to add a report using CR. I am only getting the headings, and I don't know why. Can anybody please tell me what I am doing wrong\t
VIEWS ON THIS POST

84

Posted on:

Friday 5th October 2012
View Replies!

User controls not showing up in toolbox

I'm using VS2010. I built a solution that has custom controls in it and built a test project in the same solution to test them. Everything works great like that and the controls show up in the toolbox. But in the application I want to use them in if I add a reference and add the DLL of the user controls they do not show up in the toolbox... is there something special I have to do to get them to show up when referencing the DLL
VIEWS ON THIS POST

94

Posted on:

Tuesday 9th October 2012
View Replies!

Selected text not showing for Dropdownlist control (Windows app)

I have a autocomplete dropdownlist(ddl) in my app. When ever I click on the ddl and start typing to find the item I am looking for in the ddl. The ddl is expanded to show all the orders when typing. After I press the enter key to go out and get the order information for that order the Order number in the ddl is missing but here is the weird part. When I don't have the ddl expanded but still have focus on the ddl. When I find the order I need and press enter. The order number is showing in the ddl as the selected one after it has loaded up the order information. Does anybody have any ideas on what could be causing this. Also, I am using Windows 7.
VIEWS ON THIS POST

60

Posted on:

Saturday 13th October 2012
View Replies!

showing approved requistion in a ms flexgrid

jim b | Post Points: 5 firoz.raj KSA Since 12/3/2008 Posts 589 Reputation 11,217 Reply mohammed firoz (firoz.raj) replied on 4/18/2009 10:42 PM rated by 0 users APPROVED.zip Sir i simple want when user click on approved button all the approved records should show .But it is not showing anything.here is the following code which is written forapproved_click():when i click on approved submenu it is not showing anything.Code:Private Sub mnuApproved_Click()mnuApproved.Checked = TruemnuNew.Checked = FalsemnuPending.Checked = FalsemnuCancelled.Checked = FalsemnuFullRange.Checked = FalseClearRequisitionselectedMode = approvedOrderCall LoadRequisition(selectedMode)ShowRangeInputFields TrueEnd Sub
VIEWS ON THIS POST

108

Posted on:

Saturday 13th October 2012
View Replies!

showing pic by double click

Aamir Mustafa | Post Points: 20 Russell Judge Ohio Since 2/17/2004 Posts 2,475 Reputation 15,690 Reply Russell Judge (Russell Judge) replied on 4/28/2008 6:06 AM rated by 0 users At first glance, I don't see any problems with the code. What happens when you run the code
VIEWS ON THIS POST

232

Posted on:

Saturday 13th October 2012
View Replies!

[Resolved] Ampersand symbol not showing up on label

------------------------------------------------------------------------------------------------Put your PC to good work at vbCity at world community grid and join Team vbCity.10,210,819points and ranked 1,839th as of June 23 2011!------------------------------------------------------------------------------------------------ #mce_temp_url# | Post Points: 5 T48 - [RedPlanet] Belgium, Antwerp City Since 9/12/2003 Posts 412 Reputation 4,670 Reply Wout eene (T48 - [RedPlanet]) replied on 7/2/2007 6:59 PM rated by 0 users Incase you wonder what's causing this or what purpose it has:If you want to assign keyboard shortcuts to certain controls (as Buttons, Checkboxes, Topmenus) you would give it a caption as "&Alpha" or "&Beta", wich gets translated it into "Alpha" and "Beta", wich you can access by using the keyboard shortcuts ALT+A and ALT+B to set focus on those controls.As Geof above allready mentioned, use double ampersand to get around it.(checkout the build-in Replace() function for a quick solution)
VIEWS ON THIS POST

298

Posted on:

Saturday 13th October 2012
View Replies!

Access subreport page header not showing up

------------------------------------------------------------------------------------------------Put your PC to good work at vbCity at world community grid and join Team vbCity.10,210,819points and ranked 1,839th as of June 23 2011!------------------------------------------------------------------------------------------------ #mce_temp_url# | Post Points: 35 Geof Cincinnati, OH, USA Since 4/18/2005 Posts 12,816 Reputation 90,024 Reply Geof Wyght (Geof) replied on 5/31/2007 8:00 AM rated by 0 users rptdesign.JPG So as a test, I added a page header in the subreport and added the " World" label. (See attached). But when I preview the report, I do not see the " World" label. I wonder why
VIEWS ON THIS POST

113

Posted on:

Saturday 13th October 2012
View Replies!

Records not showing up

My SiteFAQ's: System | Database | XML | Strings | Collections | Object OrientedGuidlines: Rules | Signature Limit | ''How To'' Best PracticeQuote: The greatest mistake you can make in life is to be continually fearing you will make one. Elbert Hubbard | Post Points: 5 str50 Since 12/28/2005 Posts 492 Reputation 9,225 Reply pr ra (str50) replied on 7/24/2006 4:50 PM rated by 0 users what i am trying to do is search for a record and then and save the record once i have made the changes to it. For example, in form1 i have a textbox for barcodeid, so i put it 10 and hit the search button. It should find record 10 and display all the information in form2, so I can makes changes to the record and once i am done i hit the save button to save it. Hope this helps.
VIEWS ON THIS POST

156

Posted on:

Monday 15th October 2012
View Replies!

Application crashes showing error EventType clr20r3 P1 ieplorer.exe

Our application works fine in all the PCs .but there is one PC in which our application crashes everytime during day to day activity and shows the message as shown below. and hangs forever.kindy suggest something.. EventType :clr20r3 P1 :iexplorer.exe P2:7.0.5730.13P3:undefined P4:SYSTEM.WINDOWS.FORMS P5:undefined.
VIEWS ON THIS POST

291

Posted on:

Saturday 3rd November 2012
View Replies!

Dropdownlist showing problem in IE but working fine in Mozilla Firefox

i have a dropdownlist which has a linq datasource ...and i have inserted 2 items " Batch" and "Choose" from the codebehind manully...in case of mozilla firefox "Choose" is automatically selected as default in the dropdownlist but in case of IE6 the default selection in dropdownlist is blank but the items are there if we scroll the list..... Can anyone tell me how to make it work in IE6 too...
VIEWS ON THIS POST

183

Posted on:

Wednesday 7th November 2012
View Replies!

basic problem in combo box - display member now showing up

I have a ds, that I am using to populate the combo box. problem is the ID is showing up as the display and Blank for the value member. what I want is sid is the value and snm as the text. the ds is retrieving just those 2 columns in the ds. any help would be appreciated oDa.Fill(oDs, "Survey") With ComboBox1 .DataSource = oDs.Tables("Survey") .DisplayMember = "snm" .ValueMember = "sid" End With bev
VIEWS ON THIS POST

184

Posted on:

Wednesday 7th November 2012
View Replies!

Menu's not showing?

For some reason, my menus are not showing in my application. Can anyone tell me why PublicClassForm1 InheritsSystem.Windows.Forms.Form DimintActionAsInteger DimvalArray(3,4)AsInteger #Region"WindowsFormDesignergeneratedcode" PublicSubNew() MyBase.New() 'ThiscallisrequiredbytheWindowsFormDesigner. InitializeComponent() 'AddanyinitializationaftertheInitializeComponent()call EndSub 'Formoverridesdisposetocleanupthecomponentlist. ProtectedOverloadsOverridesSubDispose(ByValdisposingAsBoolean) IfdisposingThen IfNot(componentsIsNothing)Then components.Dispose() EndIf EndIf MyBase.Dispose(disposing) EndSub 'RequiredbytheWindowsFormDesigner PrivatecomponentsAsSystem.ComponentModel.IContainer 'NOTE:ThefollowingprocedureisrequiredbytheWindowsFormDesigner 'ItcanbemodifiedusingtheWindowsFormDesigner. 'Donotmodifyitusingthecodeeditor. FriendWithEventsmenuFileAsSystem.Windows.Forms.MenuItem FriendWithEventsmenuPerformActionAsSystem.Windows.Forms.MenuItem FriendWithEventsmenuExitAsSystem.Windows.Forms.MenuItem FriendWithEventsmenuActionAsSystem.Windows.Forms.MenuItem FriendWithEventsmenuSumRowsAsSystem.Windows.Forms.MenuItem FriendWithEventsmenuSumColumnsAsSystem.Windows.Forms.MenuItem FriendWithEventsmenuAverageRowsAsSystem.Windows.Forms.MenuItem FriendWithEventsmenuAverageColumnsAsSystem.Windows.Forms.MenuItem FriendWithEventsMainMenuAsSystem.Windows.Forms.MainMenu PrivateSubInitializeComponent() Me.MainMenu=NewSystem.Windows.Forms.MainMenu Me.menuFile=NewSystem.Windows.Forms.MenuItem Me.menuPerformAction=NewSystem.Windows.Forms.MenuItem Me.menuExit=NewSystem.Windows.Forms.MenuItem Me.menuAction=NewSystem.Windows.Forms.MenuItem Me.menuSumRows=NewSystem.Windows.Forms.MenuItem Me.menuSumColumns=NewSystem.Windows.Forms.MenuItem Me.menuAverageRows=NewSystem.Windows.Forms.MenuItem Me.menuAverageColumns=NewSystem.Windows.Forms.MenuItem ' 'MainMenu ' Me.MainMenu.MenuItems.AddRange(NewSystem.Windows.Forms.MenuItem(){Me.menuFile,Me.menuAction}) ' 'menuFile ' Me.menuFile.Index=0 Me.menuFile.MenuItems.AddRange(NewSystem.Windows.Forms.MenuItem(){Me.menuPerformAction,Me.menuExit}) Me.menuFile.ShowShortcut=False Me.menuFile.Text="&File" ' 'menuPerformAction ' Me.menuPerformAction.Index=0 Me.menuPerformAction.ShowShortcut=False Me.menuPerformAction.Text="&PerformAction" ' 'menuExit ' Me.menuExit.Index=1 Me.menuExit.ShowShortcut=False Me.menuExit.Text="E&xit" ' 'menuAction ' Me.menuAction.Index=1 Me.menuAction.MenuItems.AddRange(NewSystem.Windows.Forms.MenuItem(){Me.menuSumRows,Me.menuSumColumns,Me.menuAverageRows,Me.menuAverageColumns}) Me.menuAction.ShowShortcut=False Me.menuAction.Text="&Action" ' 'menuSumRows ' Me.menuSumRows.Index=0 Me.menuSumRows.ShowShortcut=False Me.menuSumRows.Text="Sum&Rows" ' 'menuSumColumns ' Me.menuSumColumns.Index=1 Me.menuSumColumns.ShowShortcut=False Me.menuSumColumns.Text="&SumColumns" ' 'menuAverageRows ' Me.menuAverageRows.Index=2 Me.menuAverageRows.ShowShortcut=False Me.menuAverageRows.Text="A&verageRows" ' 'menuAverageColumns ' Me.menuAverageColumns.Index=3 Me.menuAverageColumns.Text="Average&Columns" ' 'Form1 ' Me.AutoScaleBaseSize=NewSystem.Drawing.Size(5,13) Me.ClientSize=NewSystem.Drawing.Size(292,266) Me.Name="Form1" Me.Text="ArrayManipulation" EndSub #EndRegion PrivateSubForm1_Load(ByValsenderAsSystem.Object,ByValeAsSystem.EventArgs)HandlesMyBase.Load valArray(0,0)=5 valArray(0,1)=7 valArray(0,2)=3 valArray(0,3)=9 valArray(0,4)=12 valArray(1,0)=4 valArray(1,1)=8 valArray(1,2)=9 valArray(1,3)=13 valArray(1,4)=4 valArray(2,0)=0 valArray(2,1)=-1 valArray(2,2)=-7 valArray(2,3)=13 valArray(2,4)=8 valArray(3,0)=4 valArray(3,1)=4 valArray(3,2)=4 valArray(3,3)=4 valArray(3,4)=0 EndSub PrivateSubmenuSumRows_Click(ByValsenderAsSystem.Object,ByValeAsSystem.EventArgs)HandlesmenuSumRows.Click menuSumRows.Checked=True menuSumColumns.Checked=False menuAverageRows.Checked=False menuAverageColumns.Checked=False intAction=1 EndSub PrivateSubmenuSumColumns_Click(ByValsenderAsSystem.Object,ByValeAsSystem.EventArgs)HandlesmenuSumColumns.Click menuSumRows.Checked=False menuSumColumns.Checked=True menuAverageRows.Checked=False menuAverageColumns.Checked=False intAction=2 EndSub PrivateSubmenuAverageRows_Click(ByValsenderAsSystem.Object,ByValeAsSystem.EventArgs)HandlesmenuAverageRows.Click menuSumRows.Checked=False menuSumColumns.Checked=False menuAverageRows.Checked=True menuAverageColumns.Checked=False intAction=3 EndSub PrivateSubmenuAverageColumns_Click(ByValsenderAsSystem.Object,ByValeAsSystem.EventArgs)HandlesmenuAverageColumns.Click menuSumRows.Checked=False menuSumColumns.Checked=False menuAverageRows.Checked=False menuAverageColumns.Checked=True intAction=4 EndSub PrivateSubmenuPerformAction_Click(ByValsenderAsSystem.Object,ByValeAsSystem.EventArgs)HandlesmenuPerformAction.Click SelectCaseintAction Case1 SumRows() Case2 SumColumns() Case3 AverageRows() Case4 AverageColumns() EndSelect EndSub PrivateSubmenuExit_Click(ByValsenderAsSystem.Object,ByValeAsSystem.EventArgs)HandlesmenuExit.Click End EndSub PrivateSubSumRows() EndSub PrivateSubSumColumns() EndSub PrivateSubAverageRows() EndSub PrivateSubAverageColumns() EndSub EndClass
VIEWS ON THIS POST

227

Posted on:

Wednesday 7th November 2012
View Replies!

MS Access> Network> Datagrid recordset not showing problem

i connect to an access database from another machine with this code cn.Open "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=\\COMP/c/db.mdb;Persist Security Info=False;Jet OLEDB:Database Password=1234" rs.open "SELECT * FROM tbl", cn, adOpenKeyset, adLockOptimistic Text1.Text = rs.Fields(0).Value it's working fine and i can get the right values, i can even move the recordset (next/previous,etc)...the problem is that when i use this Set Datagrid1.Datasource = rs nothing displays on the datagrid...i've been using that code for the datagrid for a long time, but the access database is from the local computer, and it's working fine...
VIEWS ON THIS POST

155

Posted on:

Saturday 10th November 2012
View Replies!

Data of combobox is showing in textbox when running form

Private Sub cbo1_Click() txtnm.Text = cbo1.Text End Sub 'other than _Click 'i put it in _Change also 'but when selecting item in combobox, 'no action shows
VIEWS ON THIS POST

251

Posted on:

Saturday 10th November 2012
View Replies!

Problem with showing data in ListView From the Database

...!! I'm having a problem with my ListView .. !! the problem is that when i try to show the data from the database it will show only the first column .. !! and i will get this error " Type Mismatch error " 13 " , I don't know what is the problem .. (( the version im using is windows common controls SP6 ))But when i use an older version of the listview (like SP5) it will be shown correctly ... Here is my code that im using to show the data !! : Private sub ShowList() Rs.Open "select * from tblDonors ", Cn, adOpenStatic, adLockOptimistic With ListView1 .FullRowSelect = True .View = lvwReport .ColumnHeaders.Clear .ColumnHeaders.Add , , "Barcode Number", 2000 .ColumnHeaders.Add , , "ID Number", 2000 .ColumnHeaders.Add , , "Name", 2000 .ColumnHeaders.Add , , "Gender", 2000 .ColumnHeaders.Add , , "Nationality", 2000 .ColumnHeaders.Add , , "D.O.B", 2000 .ColumnHeaders.Add , , "Address", 2000 .ColumnHeaders.Add , , "City", 2000 .ColumnHeaders.Add , , "ABO", 2000 .ColumnHeaders.Add , , "Age", 2000 .ColumnHeaders.Add , , "Phone", 2000 .ListItems.Clear Do While Not Rs.EOF Set SRC_ITEM = .ListItems.Add(, , Rs.Fields("barcode_no")) SRC_ITEM.SubItems(1) = Rs.Fields("id_no") SRC_ITEM.SubItems(2) = Rs.Fields("dname") SRC_ITEM.SubItems(3) = Rs.Fields("gender") SRC_ITEM.SubItems(4) = Rs.Fields("nationality") SRC_ITEM.SubItems(5) = Rs.Fields("dob") SRC_ITEM.SubItems(6) = Rs.Fields("address") SRC_ITEM.SubItems(7) = Rs.Fields("city") SRC_ITEM.SubItems(8) = Rs.Fields("dbgroup") SRC_ITEM.SubItems(9) = Rs.Fields("age") SRC_ITEM.SubItems(10) = Rs.Fields("phone") Rs.MoveNext Loop End With End Sub I tried my best , But really I cant find any solution for it. hope anyone can help me. best regards.
VIEWS ON THIS POST

167

Posted on:

Sunday 11th November 2012
View Replies!