Trouble with setting up my ASP pages in IIS7


Aplogies if this isnt the correct forum, my question is IIS related but there isnt an IIS forum and I am using ASP for my web pages , so here goes anyway!

Ive recently upgraded to Vista and to IIS7 for managing my web sites.
Im having trouble getting some of my site up and running, particularly
dynamic sites which run off Access databases and ASP.

The error message I get is : "You do not have permission to view this
directory or page because of the access control list (ACL)
configuration or encryption settings for this resource on the Web
server."

Ive set the Inernet Guest user account to have permissions to these
new folders but its refusing to serve the pages. Ive created a web
page detailing the user accounts and permissions Ive set up and a
screen print of the error message, link below:

http://www.pool-predictions.co.uk/problem.htm

Id greatly appreciate any tips/help.

Also, what is the 'Physical Path Credentials' bit do under the "Web
Sites Defaults" dialogue box Is that something to do with it Also
what is an 'Application Pool'

Cheers...John
Posted On: Friday 26th of October 2012 07:35:57 AM Total Views:  453
View Complete with Replies

RELATED TOPICS OF ASP PROGRAMMING LANGUAGE




Having trouble comparing count to array values

I have the following code to check if a field number matches a specific value. here is the code Code: FieldValues(0)=7 FieldValues(1)=15 FieldValues(2)=23 FieldValues(3)=31 FieldValues(4)=39 FieldValues(5)=47 FieldValues(6)=55 FieldValues(7)=63 FieldValues(8)=71 FieldValues(9)=79 FieldValues(10)=87 FieldValues(11)=95 FieldValues(12)=103 FieldValues(13)=111 Sub FieldDisp(FieldNum,FormNum,FieldString) for FieldValLen=0 to Ubound(FieldValues) If Cstr(FieldNum) = Cstr(FieldValues(FieldValLen)) Then OutputText="**"&FieldNum&"|Form:"&FormNum&""&FieldString&"" Else OutputText=""&FieldNum&"|Form:"&FormNum&""&FieldString&"" End If next End Sub I receive no errors and the count changes for each call of the sub but the If statement does not pass..(ie I never receive the ** for the array values)
VIEWS ON THIS POST

201

Posted on:

Friday 26th October 2012
View Replies!

Hey having trouble with my form's submit() in javascript

hey I have condensed the main parts of my form below. Basically it is bugging out when the .submit() method is fired. Am I missing something out My form basically does this: function dosubmit() { document.form1.action = "process.aspmode=normal&id=3"; document.form1.submit(); return = true; } /* bugging out on the document.form1.submit(), error message : Object does not support this property or method */
VIEWS ON THIS POST

195

Posted on:

Friday 26th October 2012
View Replies!

Function trouble

Ok, I've narrowed down my error to one particular function. It looks as if the function may not be receiving the variable that is passed to it. The error message is: error '80020009' results.asp, line 21 Line 21 is: Code: strsql = strsql + "AND RGnameLast = '" & RGnameLast & "' " Which is a line in the function. The whole program is: Code: Untitled Users Class Office Location Course # Subject Name Class # Original Ref. Date Objectives Results Grade Class Amount Cost Status of File Task Amount Billed Amount
VIEWS ON THIS POST

137

Posted on:

Friday 26th October 2012
View Replies!

trouble installing (testing asp) - Page 2

Originally Posted by mordy whoa! this is strange... localhost started working today.... boy is this weird probably the XP auto-restored the hosts file after is was changed. afaik you can add stuff into there but can't delete the file, for example. it would simply apear again...
VIEWS ON THIS POST

201

Posted on:

Friday 26th October 2012
View Replies!

Having trouble using value in RS

, I'm trying to look for the biggest int value in a tbl through: Code: sqlQuery = "SELECT max(pollId) AS ""maxId"" FROM pollQuestions_cdc" However I have no idea how to recuperate this information to add another number to it. The recordset with that query is qRS so I tried qRS("maxId") but when I try to response.write it comes out as a null character. How do you use these values
VIEWS ON THIS POST

209

Posted on:

Friday 26th October 2012
View Replies!

Query trouble

I am having trouble with the following query i have tried many diffrent " ' combinations but can't get it to work. Cheres Code: PROPERTY_NO LOCATION OCCUPANTS BEDROOMS PETS SMOKING MORE_INFO More Info
VIEWS ON THIS POST

170

Posted on:

Friday 26th October 2012
View Replies!

Having trouble using value in RS - Page 2

oooops, i assumed access sorry....i'll have to emulate on sql server in a bit...hopefully someone will get to it before me...if not i'll return
VIEWS ON THIS POST

174

Posted on:

Friday 26th October 2012
View Replies!

big sql trouble

there, In the code below I have an sql and then add to it depending on certain conditions. When I run it however I am getting an expected end of statment error for this line - Set objRS = objConn.Execute sqlmain I am not sure why though. I did a response.write(sqlmain) and it printed an sql with the last clause = 'value' is there something I need to finish the sql
VIEWS ON THIS POST

169

Posted on:

Friday 26th October 2012
View Replies!

IIS trouble

I am having trouble with installing IIS, I tried to do it in my control panel, but it wants the disk, I don't have the disk because my computer came with Windows XP Pro 2002 Service pack 2. so I went to the microsoft website and downloaded the free download of IIS6. Then when I go to my control panel and Administrative tools it is in there and when I click on it, there is no computer name available. Any suggestions\t\t
VIEWS ON THIS POST

182

Posted on:

Friday 26th October 2012
View Replies!

variable processing trouble

what's up fellas, i'm trying to process a form and everything works fine except the rsrateprocess("readerscore") = rsrateprocess("readerscore")+"&rank&" line. For some reason it's not adding the variable, "rank", which I tested, and it works. rsrateprocess("readerscore") is equal to 0 and when I click submit it just processes the form but doesn't execute that line correctly. What's wrong Code:
VIEWS ON THIS POST

247

Posted on:

Friday 26th October 2012
View Replies!

Having trouble calling an SQL statement...

Ok , in this specific example there's NO recordset in the table I'm searching for. What I want to do is display coding if there IS a recordset and if there's not, I don't want to display anything. Instead of displaying nothing I'm getting the following error... ADODB.Field error '80020009' Either BOF or EOF is True, or the current record has been deleted. Requested operation requires a current record. /gameinfo.asp, line 0 Code: sql = "SELECT author, reviewlink, reviewtitle FROM "&console&"reviews where reviewtitle = '"&title&"'" Set rsreview = Server.CreateObject("ADODB.Recordset") rsreview.Open sql, conn, 3, 3
VIEWS ON THIS POST

167

Posted on:

Friday 26th October 2012
View Replies!

Forum replies trouble

all. I only know the very basics of SQL and so I unfortunately can't do this. Basically I have 3 tables: Forum_categories -ForumID -ForumName -ForumDescription Forum_Messages -MessageID -ForumID -Message -User Forum_Replies -ReplyID -MessageID -Reply -User When you are on the forum categories page and you click on a category, it passes the ForumID as a url parameter to the next page. The next page is where I need the SELECT * FROM Forum_Messages WHERE ForumID = MMColParam Variables defined: MMColParam 1 Request.QueryString("ForumID") I need to combine that with the SELECT MessageID, COUNT(*) AS responses FROM Forum_Replies GROUP BY MessageID So I can show the number of replies for each message in the category chosen eg: " You are in the general category" Message 1 (3 replies) Message 2 (2 replies) Message 3 (0 replies) Can anybody help with thisI think I need to use a table join, but am note quite sure on how to do that.
VIEWS ON THIS POST

160

Posted on:

Friday 26th October 2012
View Replies!

DNS less database connection trouble

I'm trying to use a banner ads .asp program called Admentor. My problem is that this uses DNS less connection and I can't get this working on both the pages showing the ads and the admin panel. I know it's the path to the database that causes this. If I change this to suite the webpages showing ads, it work's, and if I modify it to suite the admin panel it work's. But not both at the same time. Should'nt this path be relative to the sites root g_Admentor_strConnect = "DRIVER={Microsoft Access Driver (*.mdb)};DBQ="& Server.MapPath("../ads/admentor/ad97.mdb") when using this string, the webpages showing banners is working, but when clicking on these, the site calles a redirect .asp page that also uses this database connection. Then it fails, since this page is located in another folder in the site and therefore also gets another path to the database. How can I get this to be a relative path working on all pages not been worried about folders, subfolders and correct paths to the base \t Best regards Ketil Leinum Norway
VIEWS ON THIS POST

203

Posted on:

Friday 26th October 2012
View Replies!

Having trouble adding a new record into a MySQL table

I'm having trouble adding a new record into a MySQL table. It worked fine in access but now it's not working at all. I think it's in the way I'm opening the database and trying to put it in. Here's the error and coding. ADODB.Recordset error '800a0cc1' Item cannot be found in the collection corresponding to the requested name or ordinal. /releaseprocess.asp, line 16 Code: Line 16 is.... Code: rsrelease("title") = title
VIEWS ON THIS POST

189

Posted on:

Friday 26th October 2012
View Replies!

I am having some trouble with a section of my code for amend record.

I am having an unexpected issue with some of my code, everything appeared to work fine, except when I went to edit a particular record, it messed up on me. Its more than likely some part of my code is messed up yet I have been able to update a few items already. Below is my sql for the amend and beneath that is my error message, after I tried to update a particular field. 'AMEND AN ARTICLE 'Perform the amend operation using SQL Sub amendArticle() 'Open Connection Object Response.Write (openConnection) strSQL = "UPDATE tblNews Set newsDate = '" & request("newsDate") & "',newsTitle = '" & request("newsTitle") & "',newsBody = '" & request("newsBody") &_ "'WHERE newsID = '" & newsID line 153 objConn.execute(strSQL) Response.Redirect("amend.asp") objConn.Close End Sub And here is my error after I tried to update. Error Type: Microsoft JET Database Engine (0x80040E14) Syntax error (missing operator) in query expression ''Chester's only firm of Chartered Tax Advisers',newsBody = 'Meacher-Jones Hargreaves & Woods became Chesters only firm of Chartered Tax Advisers in 2004'. /mjhw/functions/selectcase.asp, line 153 Any information as to why I am having this isssue would be great, look forward to any feedback.
VIEWS ON THIS POST

161

Posted on:

Friday 26th October 2012
View Replies!

I am having some trouble with a section of my code for amend record. - Page 2

Your gonna hate me but it still does not function. Below is my whole sub. 'AMEND AN ARTICLE 'Perform the amend operation using SQL Sub amendArticle() 'Open Connection Object Response.Write (openConnection) Dim ReplaceQuotes strSQL = "UPDATE tblNews Set newsDate = CONVERT(DATETIME, '"&request("newsDate")&"', 102),newsTitle ='" & ReplaceQuotes(request("newsTitle"))&"',newsBody ='"& ReplaceQuotes(request("newsBody"))&"' WHERE newsID = " &newsID&";" objConn.execute(strSQL) Response.Redirect("amend.asp") objConn.Close End Sub
VIEWS ON THIS POST

202

Posted on:

Friday 26th October 2012
View Replies!

Textarea trouble?

I have a textarea on a form that stores data in my db. I just finished some reports, but when I write the textarea value out to my txt report, it removes the cr and lf and just shows one long string of text. How can I format that to keep it from stretching my report off the visible page
VIEWS ON THIS POST

178

Posted on:

Friday 26th October 2012
View Replies!

array: unhandled data type trouble

I have a pretty standard sub that is coded for adding items to a cart array and im using querystrings to send the data to the Add to cart page. CART CODE: Code: SUB addtocart(itmID,itmNM,itmPR,itmOP) If Session("cartmax") = "" Then Session("cartmax") = -1 Session("cart") = Null Else cartMax = Session("cartmax") End If If cartMax = -1 Then Session("cart") = Null Cart(0,0) = itmID Cart(1,0) = 1 Cart(2,0) = itmNM Cart(3,0) = itmPR Cart(4,0) = itmOP cartMax = 0 Session("cartmax") = cartMax Session("cart") = Cart Else If IsArray(Session("cart")) Then For i = 0 to cartMax Cart(0,i) = Session("cart")(0,i) Cart(1,i) = Session("cart")(1,i) Cart(2,i) = Session("cart")(2,i) Cart(3,i) = Session("cart")(3,i) Cart(4,i) = Session("cart")(4,i) Next End If For i = 0 to cartMax If Cint(Cart(0,i)) = Cint(itmID) Then Cart(1,i) = Cint(Cart(1,i)) + 1 blnInCart = True End If Next If blnInCart True Then cartItem = addCartElement() If IsArray(Session("cart")) Then For i = 0 to cartMax Cart(0,i) = Session("cart")(0,i) Cart(1,i) = Session("cart")(1,i) Cart(2,i) = Session("cart")(2,i) Cart(3,i) = Session("cart")(3,i) Cart(4,i) = Session("cart")(4,i) Next End If Cart(0,cartItem) = itmID Cart(1,cartItem) = 1 Cart(2,cartItem) = itmNM Cart(3,cartItem) = itmPR Cart(4,cartItem) = itmOP End If Session("cart") = Cart End If END SUB and my problem is - Error Type: Response object, ASP 0106 (0x80020005) An unhandled data type was encountered. /cart/addtocart.asp Even if i manually type in the data in the querystrings it still returns this error
VIEWS ON THIS POST

234

Posted on:

Friday 26th October 2012
View Replies!

ASP Array trouble

Hi I'm having a problem with an array and was wondering if someone could help me. I have a page with a form which when it's submitted a search on a database is executed and a table is displayed on the page. The table displays some information along with some check boxes. If the user selects say two out of five check boxes, the two he has selected is two items he wants deleted from the database. Still following Now my problem is now I can't submit the form again because it already deals with the search of the database and adding a second form just seems to remove the table from the page. If there was some way I could copy an array from one asp page to another then I might be able to solve this problem. Does anyone know how it would be possible to copy an array from one asp page to another RabBell.
VIEWS ON THIS POST

194

Posted on:

Friday 26th October 2012
View Replies!

iis troubles

i am using front page, but have also started to use dreamweaver, and am getting tired of having to load up my pages everytime i need to check what ive done. i ve got a database running through asp but front page or dreamweaver does not recognise it at all. ive heard that its something to do with the IIS, i have it but havent a clue what to do with it! can anyone help me out!
VIEWS ON THIS POST

338

Posted on:

Friday 26th October 2012
View Replies!