Give me resources.


, Anybody tell me resources which works on ASP+ XML with some codes there.
Posted On: Friday 26th of October 2012 07:36:21 AM Total Views:  537
View Complete with Replies

RELATED TOPICS OF ASP PROGRAMMING LANGUAGE




ComboBox.Clear gives error

Forgive me for posting this in 2 forums. I also posted it in the Interdev forum. It doesn't get much traffic so I posted it here too. I really need to know this bad!!!!--------------------------------------------------------------------------------I have an asp page made in Visual Interdev with 5 combo boxes. I have it set up to fill one based on the contents of the other with RemoteScripting. of the data comes from a database in SQL Server 7.0.The page has worked beautifully until today. I've been using it for about 3 months in a project I'm working on. Since one combo box is based on the other, I used the following to clear the next ones in line. It is in VBScript.Sub cboTest1_Click()frmTest2.cboTest2.ClearfrmTest3.cboTest3.ClearfrmTest4.cboTest4.ClearfrmTest5.cboTest5.Clear'Fill the next oneEnd SubI did this in case the user changes a previous one again it would clear the combo boxes after the one they changed.The error says Object don't support this method or property.It is an ActiveX combo box, not html drop box.I've tried replacing the combo box and even re-installed Visual Studio. What in the hell has happened Anyone have any idea Please. It's driving me nuts!!!!!!!!!!! RobJust my $.02.
VIEWS ON THIS POST

201

Posted on:

Tuesday 16th October 2012
View Replies!

I give up....

Ok gurus, I need help real bad.I have a table with 6 fields. Fields 1-4 display data from previous input form, when my users update records from the previous form I'm populating fields 5 and 6 with updated entries. I'm good with looping data from original input 1-4 but I'm having problems looping data on fields 5-6 using a loop.I guess my question is:How do I loop fields 5-6 if 1-4 are already in a loop\t 1\t\t\t\t2\t\t\t\t\t3\t\t\t\t4\t\t\t\t\t5\t\t\t\t\t6Thank you in advance.. QUOTE OF THE DAYThe only ideas that will work for you are the ones you put to work.
VIEWS ON THIS POST

212

Posted on:

Thursday 18th October 2012
View Replies!

x = x + 1 gives illegal character

I have had some WONDERFUL help on some previous questions this morning fromjlsmithprismBDC2FesterSXS just to name a few helping me with several issues. I am now down to this one BIG BUG!!!! I have taken out ALL of my code except for the following:I keep getting illegal character for the line iNumRec = iNumRec + 1. Please someone tell me what is happening before I go back to pen and paper instead of a computer.You can see all that has been tried at Thread333-469008.
VIEWS ON THIS POST

223

Posted on:

Friday 19th October 2012
View Replies!

How to give Thread Links ??

Sometimes while answering some question, we realize that the answer has already been answered.In fact other experts give some no also.So howto find that no of a thread \t Rushi Shroff\t\t\t\t\tRushi@emqube.com"Life is beautiful."
VIEWS ON THIS POST

232

Posted on:

Monday 22nd October 2012
View Replies!

MTS gives out of memory error

Hi Friends,We are developing a site with asp.The configuration is as follows.* win NT 4.0 sp 6a (asp 2.0, mts 2.0)* sql server 7.0* exchange5.5* com developed in VB 6.0 and registered in mtsWe are facing problem when there are simultaneous hits to the site. We get either out of memory or server got disconnected from the clients or some wierd error.But at the server the mts always throws these two errorsin the event log whenever such a thing happens...in this order.1)The run-time environment has detected an inconsistency in its internal state and has terminated the process. Please contact Microsoft Product Support Services to report this error.\tInternal Check Failure on condition: m_lcBinds == 0 (Package: BIComponents)\t\t\t(Microsoft Transaction Server Internals Information: File: i:\viper\src\runtime\mtxex\activity.cpp, Line: 287)\t2)Failed on creation from object context: CreateInstance\t(ProgId: BIClasses.DBAccess) (CLSID: {EB6B72E4-D265-11D4-B02B-00D0B76A10CD}) (Interface: IUnknown) (IID: {00000000-0000-0000-C000-000000000046})\t(Microsoft Transaction Server Internals Information: File: i:\viper\src\runtime\context\ccontext.cpp, Line: 1363)\tThis happens repeatedly..We searched for these errors and found no clue as to what to do. We found in msdn that we should set retain in memory and unattended execution for vb dlls registered in mts.Even after doing there has not been any improvement.We thought this must be a problem of not having released the objects. We changed the asp code to release all the objects that we had created. Even after this the errors are continuing.And one interesting point is that the no. of concurrent hits are not mere..merely 5-10.Desperately need help
VIEWS ON THIS POST

279

Posted on:

Monday 22nd October 2012
View Replies!

ADODB.RecordSet object give me an empty value when asked for some fields.

Hi i'm having some issues with an ADODB.RecordSet object. With Classic ASP and VBScript, i'm trying to recover data from this particular object. it is connected to and local SQL Server Express 2008 R2, and it was openned with an statement like this: Code: strSQL1 ="SELECT * from ((manutint mi LEFT OUTER JOIN manutint_codDoc md ON mi.mi_documento=md.doc_cod) LEFT OUTER JOIN cliente cl ON mi.mi_cliente=cl.cli_cod) LEFT OUTER JOIN fornecedores fr on mi.mi_encaminhadoa=fr.frn_cod and mi.mi_encaminhadoa = fr.frn_cod WHERE mi.mi_status4 and " &_ " mi.mi_clientecc LIKE '"&cc&"' AND mi.mi_entrada LIKE '"&keyword22&"' order by mi.mi_cod" Set objRS1 = Server.CreateObject("ADODB.RecordSet") objRS1.Open strSQL1, objConn where cc and keyword22 are used for search purposes only. they both are simple "%" in my tests. objConn as you guess, are an ADODB.Connection object that should be working just fine, since it's used for all pages of the site and the problem is only in one page. The page code is awful big, so it would be no good to post it all. the bit that should work but dont is: Code: if Not objRS1.EOF Then objRS1.MoveFirst Do While Not objRS1.EOF Response.write "" Response.Write "" & objRS1("cli_nome")& "" Response.Write "" & objRS1("mi_dataentrada")& "" Response.Write "" & objRS1("frn_nome")& "" Response.Write "" & objRS1("mi_equipamento")& "" Response.Write "" & objRS1("mi_ns")& "" Response.Write "" & objRS1("doc_desc") &"" Response.Write "" & objRS1("mi_numdocumento") &"" Response.Write "" objRS1.MoveNext Loop End if This code is used to fill an table with the data of the objRS1, which is our ADODB.RecordSet object. this code has no erros and should work with no problem, but exactly the fields "doc_desc" and "mi_numdocumento" are showed as "", empty values. Of course I looked into the database tables and executed the exactly same SQL query in MS SQL Management Studio to check if there was data into the database in the first place, but it was ok. Also tried to search some kind of difference between the fields that work and those that don't, to no avail. also tried to do some IsNull() and other checks with the values given by objRS1, and they returned false. it as if the field's content was an "", but it is not. Did someone has ever seen something like this is there some kind of test that i could do to track down the problem that i still didn't any help or suggestion is apreciated. even an small guess. already lost 4 hours into this.
VIEWS ON THIS POST

351

Posted on:

Thursday 25th October 2012
View Replies!

My page gives no value give for one or more parameters, take a look please?

Hi here are my two pages for editing and updating my records, i get Microsoft JET Database Engine error '80040e10' No value given for one or more required parameters. /test/admin/update_record.asp, line 46 i cant see anything wrong anywhere though, ive checked again and again, anyone help\t
VIEWS ON THIS POST

260

Posted on:

Friday 26th October 2012
View Replies!

No value given for one or more required parameters.

I have created an update data base page with the help of tutorial. While submitting the data I am getting following error: Error Type: Microsoft JET Database Engine (0x80040E10) No value given for one or more required parameters. /update.asp, line 41 My code is Code: HOME SEARCH CUSTOMIZED SEARCH EDIT YOUR PROFILE
VIEWS ON THIS POST

207

Posted on:

Friday 26th October 2012
View Replies!

No value given for one or more required parameters.

Code: sql2="UPDATE Crew SET Crew_Status='" & upload.Form("crewst") & "'," sql2=sql2 & "Crew_Name='" & upload.Form("name") & "'," sql2=sql2 & "Screen_Name='" & upload.Form("screenname") & "'," sql2=sql2 & "Description='" & upload.Form("description") & "'," sql2=sql2 & "Car='" & upload.Form("car") & "'," sql2=sql2 & "Car_Img_1='" & "yes" & "'," sql2=sql2 & "Car_Spec='" & upload.Form("carspec") & "'" sql2=sql2 & " WHERE Cid= " & availableID here is the statement the sql produced which seems to be fine UPDATE Crew SET Crew_Status='Crew Member',Crew_Name='test',Screen_Name='test',Descri ption='test',Car='astra',Car_Img_1='yes',Car_Spec= 'test.' WHERE Cid= 7 please can anybody help
VIEWS ON THIS POST

301

Posted on:

Friday 26th October 2012
View Replies!

No value given for one or more required parameters.

I'm getting the error below randomly. It's happening every few minutes. Not constantly there. ***************** Microsoft JET Database Engine error '80040e10' No value given for one or more required parameters. /listclass.asp, line 53 **************** Line 53 is the rs.Open part... set rs=Server.CreateObject("ADODB.recordset") rs.Open "SELECT * FROM classifieds WHERE category = '" & Cat & "' ORDER BY classifiedsid DESC", conn There is one classified Ad in my database and it definitely has the same name "Services" as the url ... cat=Services There is also a part above that code saying this... Dim Cat Cat = request.querystring("cat") The url says.. http://www.coloradomusicbuzz.com/lis...pcat=Services Not sure why the error only happens sometimes. There is a category with the same exact name as my database says. Here is my full CODE.. its a mess I know! ******************************** Code: Please take a moment to browse through our Classifed section. Filter your results by selecting "Category". Category:   Equipment/Instrument Instruction/Lessons Musician Available Musician Wanted Plug My Band Services Other There are currently no Ads in ""
VIEWS ON THIS POST

231

Posted on:

Friday 26th October 2012
View Replies!

Can ASP send email automatically based on given date??

I've got a small app here for our sales people. Quick summary: we sell hardwood flooring and I have an app on our eBay auctions where people can request free samples. Our sales people then check this list of requests after they're shipped and calls or emails once they've received the samples. Many times the people are still quite a ways off of actually purchasing their hardwood because they're building their house and haven't even started yet. I've created a notes section where our sales people can insert notes for when they should contact again, etc. Then I have another page that shows only the requests with notes. This works ok, however, they'd like to be able to select a date in which to be reminded about the customer so they don't have to continuously check this page and scroll through all the notes. Can this be done with ASP If I were place a little calendar thing on my page so they could just select a date to be reminded could an email be sent automatically on that date Any information on this would be greatly appreciated.
VIEWS ON THIS POST

283

Posted on:

Friday 26th October 2012
View Replies!

How I make to receive given from a XML

How I make to receive given from a XML Communication with API in Java. I am to use the following code: user = "cosat" pass = "cosat" dim objXMLHTTP set objXMLHTTP = Server.CreateObject("Microsoft.XMLHTTP") objXMLHTTP.Open "POST", "http://localhost:8081/soap/servlet/rpcrouter", false objXMLHTTP.setRequestHeader "Content-Type", "text/xml" 'Login API strPost = "" strPost = strPost & "" strPost = strPost & "" strPost = strPost & ""&user&"" strPost = strPost & ""&pass&"" strPost = strPost & "" strPost = strPost & "" strPost = strPost & "" 'Fim Login API 'Lista Empresas strPost = "" strPost = strPost & "" strPost = strPost & "" strPost = strPost & "" strPost = strPost & "" strPost = strPost & "" 'Fim Lista Empresas 'Lista Estabelecimentos strPost = "" strPost = strPost & "" strPost = strPost & "" strPost = strPost & "99" strPost = strPost & "" strPost = strPost & "" strPost = strPost & "" 'Fim Lista Empresas 'Lista Empregados strPost = "" strPost = strPost & "" strPost = strPost & "" strPost = strPost & "1607" strPost = strPost & "" strPost = strPost & "" strPost = strPost & "" 'Fim Lista Empregados objXMLHTTP.Send(strPost) Response.Write(objXMLHTTP.responseText)
VIEWS ON THIS POST

234

Posted on:

Friday 26th October 2012
View Replies!

ADODB.RecordSet object give me an empty value when asked for some fields.

Hi i'm having some issues with an ADODB.RecordSet object. With Classic ASP and VBScript, i'm trying to recover data from this particular object. it is connected to and local SQL Server Express 2008 R2, and it was openned with an statement like this: Code: strSQL1 ="SELECT * from ((manutint mi LEFT OUTER JOIN manutint_codDoc md ON mi.mi_documento=md.doc_cod) LEFT OUTER JOIN cliente cl ON mi.mi_cliente=cl.cli_cod) LEFT OUTER JOIN fornecedores fr on mi.mi_encaminhadoa=fr.frn_cod and mi.mi_encaminhadoa = fr.frn_cod WHERE mi.mi_status4 and " &_ " mi.mi_clientecc LIKE '"&cc&"' AND mi.mi_entrada LIKE '"&keyword22&"' order by mi.mi_cod" Set objRS1 = Server.CreateObject("ADODB.RecordSet") objRS1.Open strSQL1, objConn where cc and keyword22 are used for search purposes only. they both are simple "%" in my tests. objConn as you guess, are an ADODB.Connection object that should be working just fine, since it's used for all pages of the site and the problem is only in one page. The page code is awful big, so it would be no good to post it all. the bit that should work but dont is: Code: if Not objRS1.EOF Then objRS1.MoveFirst Do While Not objRS1.EOF Response.write "" Response.Write "" & objRS1("cli_nome")& "" Response.Write "" & objRS1("mi_dataentrada")& "" Response.Write "" & objRS1("frn_nome")& "" Response.Write "" & objRS1("mi_equipamento")& "" Response.Write "" & objRS1("mi_ns")& "" Response.Write "" & objRS1("doc_desc") &"" Response.Write "" & objRS1("mi_numdocumento") &"" Response.Write "" objRS1.MoveNext Loop End if This code is used to fill an table with the data of the objRS1, which is our ADODB.RecordSet object. this code has no erros and should work with no problem, but exactly the fields "doc_desc" and "mi_numdocumento" are showed as "", empty values. Of course I looked into the database tables and executed the exactly same SQL query in MS SQL Management Studio to check if there was data into the database in the first place, but it was ok. Also tried to search some kind of difference between the fields that work and those that don't, to no avail. also tried to do some IsNull() and other checks with the values given by objRS1, and they returned false. it as if the field's content was an "", but it is not. Did someone has ever seen something like this is there some kind of test that i could do to track down the problem that i still didn't any help or suggestion is apreciated. even an small guess. already lost 4 hours into this.
VIEWS ON THIS POST

218

Posted on:

Friday 26th October 2012
View Replies!

No value given for one or more required parameters.

This crazy query works on three other sites, which are all exactly the same and even use the exact same code and data format, but it won't work on a new one. The craziest part is that when I copy the query to Access and execute it in SQL view, I don't get an error; it works perfectly. Any ideas - Brad UPDATE Carts SET UserNameFull='qwer qwer',BillToAddress1='v',BillToAddress2=v,BillToCi ty=v,BillToState='AL',BillToZip='33333',BillToCoun try='1',BillPhoneDay='222-222-2222',BillPhoneNight='222-222-2222',ShipToName='qwer v,ShipToAddress1=v,ShipToAddress2=v,ShipToCity=v,S hipToState='AL',ShipToZip='33333',ShipToCountry='1 ',ShipToEmail='ataxia1@hotmail.com',UserEmail='ata xia1@hotmail.com',ShipPhoneDay='222-222-2222',ShipPhoneNight='222-222-2222',UserCompany=Null,IsResidential='Residential' ,CC_NameOnCard='qewrqwerq werqwer',CC_Type=1,CC_Date=#7/1/2004#,CC_Number='1111222233334444',Referer='2',Car tUser=365,CartModified=#7/3/2004 9:05:47 AM# WHERE CartID={202AE144-712A-4541-93D8-1967185E97AE} Microsoft JET Database Engineerror '80040e10' No value given for one or more required parameters. /sps/checkout.asp, line 186
VIEWS ON THIS POST

159

Posted on:

Friday 26th October 2012
View Replies!

(Urgent) Help me with database connection with acess in ASP? Code given. Thank You

Can someone please help me with this ASp script What i am tryiong to do Trying to connect to access database Is DSN set Yes Operationg System XP Prof DSN Name NW
VIEWS ON THIS POST

215

Posted on:

Friday 26th October 2012
View Replies!

create a folder and give it the name entered in a form

coders...Does anyone know how to create a folder in the code below and where the folder gets its name from the input in a form(bottom). I've tried file.SaveAs(Request.Form("nameName") & "/" & file.FileName) AND file.SaveAs(fileUpload.Form("nameName") & "/" & file.FileName) on line 20 but all I get is Request object error 'ASP 0207 : 80004005' Cannot use Request.Form /stud56/excr/upload.asp, line 28 Cannot use Request.Form collection after calling BinaryRead. OR aspSmartUpload.File error '80040460' Unable to save file (Error 1120) /stud56/excr/upload.asp, line 33 'Page.asp 'Page1.asp What should I do
VIEWS ON THIS POST

194

Posted on:

Friday 26th October 2012
View Replies!

Jet Database Error '80040e10'... No value given...

I am not too familiar with .asp but I have been working with it for the past few days now. I am using a program called ASP/PHP Web Application Builder to generate the .asp code so I can search a MS Access Database I created (the program pretty much generates the .asp files neccesary for having an advanced search of a database). The generated code works great. I can search the rather large database with a text box/search submit button. However there is one problem,!which occurs when I run the search and it comes back with so many responses there are multiple pages. The page will come up fine showing all results similar to a website search engine. On the bottom will also be the list of how many pages the results are listed in ( Page: 1,2,3,4,5....). You can click on each number and it will take you to that page fine, for the first time at least...(Say I search and the results come in 5 pages, I automatically start on PAGE 1, I click PAGE 5, and it takes to PAGE 5 perfectly. From there I want to go to another page..PAGE 3. That doesnt work at all. Same with any other page after that. The only way to go to PAGE 3 from PAGE 5 would be to hit me browser's "BACK" button to PAGE 1 and then click PAGE 3) Now when i say it gives me an error... this is the exact error: Error Type: Microsoft JET Database Engine (0x80040E10) No value given for one or more required parameters. /test/includes/utils.asp, line 1092 I believe the code for "utils.asp" would be a bit much to post here being it has 1500 lines or so.. The last line here is where it says the error occurs. Is something not bound correctly I really couldn't be sure because I have never work with this code before. function GetMatchingRecords(sSQL,iPageSize,iCursorLocation, Conn,RecordSet,iPage,iTotalPages,sError1,sError2,s TextBoxHighlightColor,sSearchAgain) sSQL = replace(sSQL,"[037PERCENT]","%") sSQL = ESCAPESQL(sSQL) Set RecordSet = Server.CreateObject("ADODB.Recordset") RecordSet.PageSize = iPageSize RecordSet.CacheSize = iPageSize RecordSet.CursorLocation = iCursorLocation RecordSet.CursorType = 3 Recordset.Open Conn, 3, 1, &H0001
VIEWS ON THIS POST

145

Posted on:

Friday 26th October 2012
View Replies!

SQL instruction gives an error using ASP

Can any one help, I am new to asp classic and have been working through a book called ASP made Simple. I am stuck on part of the code I am trying which is the following; I don't know why its giving me errors Can any one help please. Thank you query="select id, type,location,brief,verbose,email,wages from employ" where (cont="& y &") and ("type like '%"& x &"%' or location like '%"& x &"%' or brief like '%"& x &"%' or verbose like '%"& x & "%' or email like '%"& x & "%' or wages like '%"& x & "%' ")"
VIEWS ON THIS POST

260

Posted on:

Friday 26th October 2012
View Replies!

No value given for one or more required parameters error please help!

It will import the first name and last name fields but none of the other's i get an error message when i try to import any of them....any suggestions Untitled Document dim intMemberID as String Sub Page_Load(s as object, e as eventargs) If Session("ValidUser") "Y" Response.Redirect ("logon.aspx") End If If not page.ispostback intMemberID = Session("FMemberID") Memlbl.Text = Session("FMemberID") dim objConn as new OleDBConnection("Provider=Microsoft.Jet.OLEDB.4.0; Data Source=C:/inetpub/wwwroot/fpstudents/teamf/IUser/systemsanalysis.mdb;") dim cmdEvent As OleDbCommand dim strgetEvent As String = "Select FirstName, LastName, AddressCityState, Phone, Email, RelMember, Birthdate, Occupation, EmpName, PassW, Cell, Gender from MemberTable where MemberID =@MemberID" dim objReader As OleDBDataReader objConn.open cmdEvent= New OleDbCommand(strgetEvent, objConn) cmdEvent.Parameters.Add("@MemberID",intMemberID) objReader = cmdEvent.ExecuteReader While objReader.Read() fnametxt.Text = objReader("FirstName") lnametxt.Text = objReader("LastName") addresstxt.Text = objReader("AddressCityState") phonetxt.Text = objReader("Phone") emailtxt.Text = objReader("Email") relationtxt.Text = objReader("RelMember") birthtxt.Text = objReader("Birthdate") occupationtxt.Text = objReader("Occupation") empnametxt.Text = objReader("EmpName") passtxt.Text = objReader("PassW") celltxt.Text = objReader("Cell") gendertxt.Text = objReader("Gender") End while objReader.Close() objConn.Close() objConn = Nothing End if End Sub Sub btnEdit_Click(s as object, e as eventargs) If Page.IsValid then Dim strConnect As string dim objConn1 as new OleDBConnection strConnect ="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:/inetpub/wwwroot/fpstudents/teamf/IUser/systemsanalysis.mdb;" objConn1 = New OleDBConnection(strConnect) objConn1.open dim cmd As New OleDBCommand cmd.Connection = objConn1 cmd.commandText = "Update MemberTable " & _ "set FirstName ='" & fnametxt.text & "', " & _ "LastName ='" & lnametxt.text & "', " & _ "AddressCityState ='" & addresstxt.text & "', " & _ "Phone ='" & phonetxt.text & "', " & _ "Email ='" & emailtxt.text & "', " & _ "RelMember ='" & relationtxt.text & "', " & _ "Birthdate ='" & birthtxt.text & "' , " & _ "Occupation ='" & occupationtxt.text & "', " & _ "EmpName ='" & empnametxt.text & "', " & _ "PassW ='" & passtxt.text & "', " & _ "Cell ='" & celltxt.text & "' " & _ "Gender ='" & gendertxt.text & "' " & _ "where MemberID = " & Memlbl.text cmd.ExecuteNonQuery() objConn1.close() Response.redirect("membermain.aspx") end if End Sub
VIEWS ON THIS POST

240

Posted on:

Friday 26th October 2012
View Replies!

Update record gives me a date with my time. Need Help..

Here is the deal, Bill! I am updating my file using the "UPDATE field, var..." format. The problem is that I'm able to update my field but when I go to check the field I have a date included within the field. Ex: the field is only suppose to display the time say 12:00 AM. But what I seem to get is 1/1/1900 12:00 A.M. Can anyone explain why this is occuring. I check the input and the output which seems to be correct without the dates. My conclusion after tracking it for a minute is that its occuring within the SQL when its updating. In the SQL I'm using datetime for the field, would this cause it to display the date and time.. Vision: the ability to see the invisible...
VIEWS ON THIS POST

294

Posted on:

Friday 26th October 2012
View Replies!